WordPress.org

Ready to get started?Download WordPress

Forums

Snapshot Backup
cant get it to work (8 posts)

  1. dr730
    Member
    Posted 2 years ago #

    getting these errors:

    Warning: filesize() [function.filesize]: stat failed for /home/texasgun/public_html/theoutdoorslist.com/wordpress/wp-content/uploads/prefix-snapshot-6-2-11-9:13.tar-snapshot-20110602-1413.tar in /home/texasgun/public_html/theoutdoorslist.com/wordpress/wp-content/plugins/snapshot-backup/includes/download-recent.php on line 11

    Warning: filemtime() [function.filemtime]: stat failed for /home/texasgun/public_html/theoutdoorslist.com/wordpress/wp-content/uploads/prefix-snapshot-6-2-11-9:13.tar-snapshot-20110602-1413.tar in /home/texasgun/public_html/theoutdoorslist.com/wordpress/wp-content/plugins/snapshot-backup/includes/download-recent.php on line 12

    The size of this snapshot is 0 MB and was created on January 01 1970 at 00:00:00.

    Any advice is appreciated. Thanks.

    http://wordpress.org/extend/plugins/snapshot-backup/

  2. Jay Versluis
    Member
    Plugin Author

    Posted 2 years ago #

    Hi there,

    I'm scratching my head over this one. Several people have reported this problem, it's a server issue. I can't replicate the issue at all and hence it's really difficult for me to fix it.

    Wo are you hosting with?

  3. nilsnh
    Member
    Posted 2 years ago #

    I landed here, after searching for a solution for the same problem.

    My host is Netpower, and they're running their servers in php safe mode. I haven't read up on the specifics on that mode (besides it's to be deprecated in later PHP versions), but I believe it restricts certain commands even though CHMOD is set to "777", for the upload folder.

  4. Jay Versluis
    Member
    Plugin Author

    Posted 2 years ago #

    Hi nilsnh,

    that's a great thought - thank you! Let me investigate this - I'll have an aswer for you shortly.

  5. dr730
    Member
    Posted 2 years ago #

    I am hosting with mybbwebhost.com

  6. Jay Versluis
    Member
    Plugin Author

    Posted 2 years ago #

    Guys,

    I've just checked and it's definitely the PHP Safe Mode setting on the server that's hosting your sites. With Safe Mode on the script executes really fast but doesn't write a file. On my server I still don't get the error messages, but I do get a 0MB file when Safe Mode is on.

    As your host to switch it off and you should be fine. Please let me know if this works. I'll implement a Safe Mode check in the next release.

  7. nilsnh
    Member
    Posted 2 years ago #

    Thanks for getting back to us. :)

    I've been in contact with my host some while back, and they said they wouldn't or couldn't deactivate PHP Safe Mode. Well well. So, I guess I'll have to backup the "hard way" until further.

  8. Jay Versluis
    Member
    Plugin Author

    Posted 2 years ago #

    There are other solutions that do an even better job at backing up your site:

    Vaultpress.com
    BackupBuddy
    BlogVault

    They all cost money but are excellent at what they do.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic