WordPress.org

Ready to get started?Download WordPress

Forums

SmugMug Responsive Slider
No settings available on settings page (9 posts)

  1. drfingerless
    Member
    Posted 1 year ago #

    I have just installed the SmugMug Responsive Slider and across the top of the page is a message saying:
    'SmugMug Responsive Slider needs to be authorized before use. To start the process, please click here'.
    Clicking on that link takes me to a page titled Smugmug Slider Settings but unfortunately nothing else on the page i.e. no settings to set. Any help? Website is http://www.blackdiamondphotography.net

    http://wordpress.org/extend/plugins/smugmug-responsive-slider/

  2. Michael
    Member
    Plugin Author

    Posted 1 year ago #

    drfingerless,
    Before the settings will appear, you first need to authenticate the plugin with your SmugMug account.

    First, go to the settings page and select the "Delete SmugMug Authorization" button (the one in the red box). This will refresh the activation.

    The, follow the steps to authorize the plugin to your account. From the Smug Mug Setting Page:

    "Start Activation" button -> "Click here to log into SmguMug" button -> log into SmugMug and approve the app -> "Authorization Complete Let's Finish This" button.
    That's it. You will now see the settings page and can start using the plugin.

  3. drfingerless
    Member
    Posted 1 year ago #

    Michael, when you say 'first go to the settings page' do you mean the Smugmug settings page (in my Smugmug account) or the settings page for the slider plugin within my WordPress dashboard? If the latter then as I said before there are no options on this page. There is just a plugin heading (see this screenshot). Clicking on the red 'click here' link just takes me back to this page.
    So I can't locate your 'Delete SmugMug Authorization' button.

  4. Michael
    Member
    Plugin Author

    Posted 1 year ago #

    I am talking about the plugin setting page on your WordPress Dashboard.
    Deactivate and delete the plugin. Then reinstall it. This will delete any traces of the plugin and start fresh. Then go through the activation process again.
    You are also on an older version of WordPress, I would update to the newest version.

  5. drfingerless
    Member
    Posted 1 year ago #

    Michael we are using WordPress 3.4.1 which I believe is the latest version. I have also previously tried deactivating and deleting the plugin and reinstalling and that didn't seem to make any difference. I have also deactivated all my other plugins to see if there might be an incompatibility. All to no avail.

  6. Michael
    Member
    Plugin Author

    Posted 1 year ago #

    So sorry about the WP update, wrong screenshot, my bad. Send me an email through our contact page and I can help you dig deeper into this. Not sure why it's not showing for you... http://pokayoke.co/contact-us/

  7. Michael
    Member
    Plugin Author

    Posted 1 year ago #

    It looks like for some reason the call to SmugMug to get the temp token is getting blocked or it just times out.

    $d = $pydsmug_pydapi->auth_getRequestToken();

    If I comment out this line in the settings page, it will show the button. This issue most likely points to your server. I would take a look at your logs or call you company and see if there is a reason this is timing out or being blocked.

  8. managenet
    Member
    Posted 1 year ago #

    Hi Michael,

    The issue is likely that their server clock is off - if it has drifted enough, the auth token won't work.

    Have them set their server clock and all should be good (eg. on Ubuntu server: sudo ntpdate time.nist.gov)

    I've run into this before with Smugmug auth

  9. drfingerless
    Member
    Posted 1 year ago #

    Michael & Managenet, hosting company said that they sync on a regular basis to a number of servers and that their server clock timing lines up perfectly.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic