WordPress.org

Ready to get started?Download WordPress

Forums

smartFolio
Some albums don't load correcly (2 posts)

  1. shuey79
    Member
    Posted 1 year ago #

    all albums should redirect from /portfolio/ to /smartfolios/[album_name]. Some of my albums don't do this. As an example check out: http://nat-land.com/portfolio/ and click on "Terrace Wall" or even "Landscaped front entryway". They should redirect the user like the other albums do.
    How can I fix this?

    http://wordpress.org/extend/plugins/smartfolio/

  2. NolanD626
    Member
    Plugin Author

    Posted 1 year ago #

    Okay here's what I think it is.

    The post title is automatically generated from the album title metafield(at the very top of the create album admin page).

    The first time you update or publish the post the WP Post title is set using the top meta field (the label for it might be messed up but very top).

    i.e the album was saved without a title and then the title was later updated. which saved that album post by ID number instead of the title. And updating it won't help.

    this is your current output on one messed up link...

    <div id="right"><p id="odd"></p><p class="title">Landscaped front entryway</p><a href="347"><img width="300" border="0" height="300" class="rounded-half" title="" alt="" src="http://nat-land.com/wp-content/uploads/2012/09/179_1944x1296.jpg"></a><p></p></div>

    Which should have processed something like this...

    <div id="right"><p id="odd"></p><p class="title">Landscaped front entryway</p><a href="landscaped-front-entryway"><img width="300" border="0" height="300" class="rounded-half" title="" alt="" src="http://nat-land.com/wp-content/uploads/2012/09/179_1944x1296.jpg"></a><p></p></div>

    which should give a page at this address

    http://nat-land.com/portfolio/landscaped-front-entryway

    but it appears to 404 probably because that post is saved by id, which will not load the template. The template is loaded when the post type matches based on url format.

    Basically delete that album repost a new one and it will probably work but it might or might not append the address of the album depending on how the album was orignally saved. You might end up with and address like this.

    http://nat-land.com/portfolio/landscaped-front-entryway-2

    Basically start with the album title first in case you publish it on accident and it should work.

    BTW glad to see someone else got it working and styled fairly well for them. Kudos to you.

    One key piece of advice that I don't mean to sound rude about but get rid of that comic sans font, in my own opinion I like comic sans but it's generally hated and is statistically proven to be the least effective font in professional sales presentations.

    Sans Serif Fonts look much more clean modern and professional.

    OpenSans and Droid Sans look super clean in this portfolio plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.