WordPress.org

Ready to get started?Download WordPress

Forums

Smarter Navigation
Smarter navigation works with "ugly permalinks" only... (10 posts)

  1. james.d
    Member
    Posted 3 years ago #

    I'm using "Smarter navigation" plugin on my site, but it works perfectly only when I use "ugly permalinks" (e.g. http://example.com/?p=N).

    When I changed the permalinks to one of "pretty permalinks" (e.g. http://example.com/category/post-name/), then it doesn't function as intended. Any idea what has caused this problem?? I certainly want to avoid using "ugly permalinks", so hopefully there's a solution.

    What I mean by "it doesn't function as intended." is that when you first go to a post via category, and click previous or next, it doesn't move to the previous/next post in the chosen category. It simply moves to a previous/next post (regardless of a category).

  2. mikegoodstadt
    Member
    Posted 3 years ago #

    I would also like confirmation of this...

  3. scribu
    Member
    Plugin Author

    Posted 3 years ago #

    Please post the code you are using to display the navigation.

  4. mikegoodstadt
    Member
    Posted 3 years ago #

    I use the Hybrid theme and basically changed "link" to "smart".
    What wasn't/isn't clear is whether the various variables of the original are still operational? Could this be creatign the error?

    <div class="navigation-links">
    	<?php previous_post_smart( '%link', '<span class="previous ES">' . __( 'Anterior Diseño', 'hybrid' ) . '</span>', TRUE, '-13' ); ?>
    	<?php previous_post_smart( '%link', '<span class="previous EN">' . __( 'Previous Design', 'hybrid' ) . '</span>', TRUE, '-13' ); ?>
    	<?php next_post_smart( '%link', '<span class="next ES">' . __( 'Siguiente Diseño', 'hybrid' ) . '</span>', TRUE, '-13' ); ?>
    	<?php next_post_smart( '%link', '<span class="next EN">' . __( 'Next Design', 'hybrid' ) . '</span>', TRUE, '-13' ); ?>
    </div>

    many thanks,
    Mike

  5. scribu
    Member
    Plugin Author

    Posted 3 years ago #

    There's an extra parameter in between that I should probably get rid of.

    Anyway, try this:

    <?php previous_post_smart( '%link', '<span class="previous ES">' . __( 'Anterior Diseño', 'hybrid' ) . '</span>', TRUE, TRUE, '-13' ); ?>
    <?php next_post_smart( '%link', '<span class="next EN">' . __( 'Next Design', 'hybrid' ) . '</span>', TRUE, TRUE, '-13' ); ?>
  6. mikegoodstadt
    Member
    Posted 3 years ago #

    Nope - still category hopping...
    try from here:
    http://www.lavernia.com/category/packaging/
    select a design and see (from the menu font highlight) the categories changing.

    Can you describe how this is reconstructing the links? Maybe the permalinks are causing the probs - will try now switching back to defaults...

  7. mikegoodstadt
    Member
    Posted 3 years ago #

    Nope changing permalinks does not rectify the problem.

  8. james.d
    Member
    Posted 3 years ago #

    Mine is pretty simple. Somehow only works with "ugly permalinks". Thank you for your help.

    <div class="navigation">
    <div class="alignleft"><?php previous_post_smart('%link', 'Previous', true); ?> </div>
    <div class="alignright"><?php next_post_smart('%link', 'Next', true); ?> </div>
    </div>
  9. james.d
    Member
    Posted 3 years ago #

    Any reason why the plugin only works with "ugly permalinks" and doesn't work with "pretty permalinks"?

    Thank you for your advice.

  10. ChristineEverydayDisasters
    Member
    Posted 3 years ago #

    I thought I had the same problem until I deactivated all my plug-ins. Not terribly surprisingly AStickyPostOrderER did not play nicely with this plug-in. (or it did not play nicely with AStickyPostOrderER :-) )

    Incidently , it might be more helpful to users if your excerpt in the plug-in listing were a bit more focused on what the plugin does.

    Thanks for the great plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic