WordPress.org

Ready to get started?Download WordPress

Forums

Smart WYSIWYG Blocks Of Content
smart block not working on custom wordpress pages (2 posts)

  1. developdesign
    Member
    Posted 3 years ago #

    I tested the problem using both a child theme ( bintero ) and the default twentyten theme. On twentyten, the default index.php ( home page ) displayed the smart code, but the default category page ( news, properties ) didn't work on both themes.

    How do I check if a query is closed or not ( other than manually scanning code ). I'm using BBEdit. Could you possibly check the code on the two pages and see if you any issues?

    Can you also suggest any web site I should post this question?

    Here's the categories.php page:

    `<?php
    /**
    * The template for displaying Category Archive pages.
    *
    * @package WordPress
    * @subpackage Twenty_Ten
    * @since Twenty Ten 1.0
    */

    get_header(); ?>

    <div id="container">
    <div id="content" role="main">

    <h1 class="page-title"><?php
    printf( __( 'Category Archives: %s', 'twentyten' ), '<span>' . single_cat_title( '', false ) . '</span>' );
    ?></h1>
    <?php
    $category_description = category_description();
    if ( ! empty( $category_description ) )
    echo '<div class="archive-meta">' . $category_description . '</div>';

    /* Run the loop for the category page to output the posts.
    * If you want to overload this in a child theme then include a file
    * called loop-category.php and that will be used instead.
    */
    get_template_part( 'loop', 'category' );
    ?>

    </div><!-- #content -->
    </div><!-- #container -->

    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

    And the home page template:
    <?php
    /*
    Template Name: Front Page
    */

    //Display the header

    get_header(); ?>

    <div id="container">
    <div id="content" role="main">

    <?php
    //code to display slideshow
    get_a_post(29); ?>
    <?php the_content(); ?>

    <?php
    //code to display most recent news article
    query_posts('showposts=1&cat=5');
    while(have_posts()) : the_post(); ?>

    <h2 class="entry-title"><?php the_category(3); ?></h2>
    <h2 class="entry-title"><a href="<?php the_permalink() ?>" rel="bookmark"><?php the_title(); ?></a></h2>
    <div class="entry">
    <?php the_excerpt(); ?>
    </div>

    <?php endwhile; ?>

    <?php
    $post_id = 134;
    $queried_post = get_post($post_id);
    $content = $queried_post->post_content;
    $content = apply_filters('the_content', $content);
    $content = str_replace(']]>', ']]>', $content);
    echo $content;
    ?>

    </div><!-- #content -->
    </div><!-- #container -->

    <?php get_sidebar();
    //Display sidebar
    ?>

    <?php get_footer();
    //Display the footer
    ?>`

    http://wordpress.org/extend/plugins/smart-wysiwyg-blocks-of-content/

  2. Coen Jacobs
    Member
    Plugin Author

    Posted 3 years ago #

    Version 0.5 should fix this issue, several tweaks to prevent the plugin loops from breaking the main loop.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic