WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Smart Archives Reloaded] list and fancy modes don't work (8 posts)

  1. beggers
    Member
    Posted 3 years ago #

    Somewhere along the the line Smart Archives Reloaded stopped working properly. The only mode that works now is the block mode. The list, both and fancy modes don't work at all -- it's like the HTML page is broken. When I try those modes all I see under my header is the code <a href=" and the rest of the page is blank.

    The list mode used to work fine, but one possible issue is that I have 3500+ posts.

    The link to my archives is: http://www.vegasnews.com/archives

    Any thoughts? Thanks!

  2. scribu
    Member
    Posted 3 years ago #

    It looks like it's timing out while generating the archives.

    Try excluding a category with a lot of posts and see if the list is generated when there are fewer posts.

  3. beggers
    Member
    Posted 3 years ago #

    scribu, great to hear from you, and you were absolutely right! I tried excluding my biggest category and it works fine. Wow, this is the first time I've seen the Fancy mode -- very cool!

    Incidentally, I had tried changing the memory allocation in php.ini from 32M to 64M but that didn't help this problem.

    Any idea about a solution? Many thanks!

  4. scribu
    Member
    Posted 3 years ago #

    Besides the memory limit, you could try increasing the max execution time limit. It's usually set to 30 seconds.

  5. beggers
    Member
    Posted 3 years ago #

    I tried increasing the max execution time to 120 but it still doesn't produce any output. I'm wondering if the script itself could define more execution time for itself. This is way over my head, though.

    Right now the only way I can get fancy output is to exclude my largest category (about 2500 posts out of 3600).

  6. scribu
    Member
    Posted 3 years ago #

    Try adding this line to your wp-config.php file and see if you get any useful error message:

    define('WP_DEBUG', true);

  7. beggers
    Member
    Posted 3 years ago #

    I turned on debug and got quite a few errors on my archives page. Not sure that any are related to Smart Archives, though.

    Notice: Trying to get property of non-object in /var/www/vhosts/vegasnews.com/httpdocs/wp-includes/general-template.php on line 366
    
    Notice: Undefined index: aioseop_migrate in /var/www/vhosts/vegasnews.com/httpdocs/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 537
    
    Notice: Undefined index: aioseop_migrate_options in /var/www/vhosts/vegasnews.com/httpdocs/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 538
    
    Notice: Undefined index: aiosp_enabled in /var/www/vhosts/vegasnews.com/httpdocs/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 688
    
    Notice: Undefined index: aiosp_enabled in /var/www/vhosts/vegasnews.com/httpdocs/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 688
    
    Notice: Use of undefined constant MAX_RECENTLY_VIEWED_LINKS - assumed 'MAX_RECENTLY_VIEWED_LINKS' in /var/www/vhosts/vegasnews.com/httpdocs/wp-content/plugins/recently-viewed-posts/recentlyviewedposts.php on line 47
    
    Notice: Use of undefined constant MAX_RECENTLY_VIEWED_LINKS - assumed 'MAX_RECENTLY_VIEWED_LINKS' in /var/www/vhosts/vegasnews.com/httpdocs/wp-content/plugins/recently-viewed-posts/recentlyviewedposts.php on line 48
    
    Notice: Undefined index: postviews_id in /var/www/vhosts/vegasnews.com/httpdocs/wp-content/plugins/wp-postviews/wp-postviews.php on line 646
    
    Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of array_walk(). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /var/www/vhosts/vegasnews.com/httpdocs/wp-content/plugins/wp-useronline/wp-useronline.php on line 122
    
    Notice: Undefined offset: 1 in /var/www/vhosts/vegasnews.com/httpdocs/wp-content/plugins/wp-ban/wp-ban.php on line 108
    
    Notice: Use of undefined constant title - assumed 'title' in /var/www/vhosts/vegasnews.com/httpdocs/wp-content/plugins/where-did-they-go-from-here/where-did-they-go-from-here.php on line 238
    
    Notice: Use of undefined constant add_to_content - assumed 'add_to_content' in /var/www/vhosts/vegasnews.com/httpdocs/wp-content/plugins/where-did-they-go-from-here/where-did-they-go-from-here.php on line 239
    
    Notice: get_settings is deprecated since version 0.0! Use get_option() instead. in /var/www/vhosts/vegasnews.com/httpdocs/wp-includes/functions.php on line 2970
    
    Notice: Undefined variable: bcn_titlearray in /var/www/vhosts/vegasnews.com/httpdocs/wp-content/plugins/breadcrumb-navigation-xt/breadcrumb-navigation-xt.php on line 226
    
    Notice: Undefined variable: page_result in /var/www/vhosts/vegasnews.com/httpdocs/wp-content/plugins/breadcrumb-navigation-xt/breadcrumb-navigation-xt.php on line 247
  8. beggers
    Member
    Posted 3 years ago #

    I thought you might be interested in knowing that I got the Fancy Mode working. For an unrelated reason I had to increase the allocated memory in PHP.INI to 128M. This also made Smart Archives work again in fancy mode!

    http://www.vegasnews.com/archives

    It takes a couple of seconds for the page to display, but keep in mind that I have over 3600 posts.

    Now that I've seen the output I'm thinking that bullets might make it a little more clear. Hopefully I can figure that out from your docs. Thanks again for all the help.

Topic Closed

This topic has been closed to new replies.

About this Topic