WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Smart Archives Reloaded] Fancy archive not working (22 posts)

  1. mov
    Member
    Posted 4 years ago #

    I installed "Smart Archives Reloaded" (v. 1.7) and i can see the page with the archive, but the Fancy style doesn't working.
    I have this line of code <?php wp_footer(); ?> in the theme footer.php.
    I checked the source of page and i don't find the reference for "fancy-archives.css" or the script for jQuery Tabs.
    Any idea?

    TIA,
    mov

    http://wordpress.org/extend/plugins/smart-archives-reloaded/

  2. scribu
    Member
    Posted 4 years ago #

    Can you share the link to your site so I can have a look for myself?

  3. Kristina
    Member
    Posted 4 years ago #

    The fancy archives aren't working in IE. They work fine in FF. Can you take a look at my site and tell me what's going on? http://kristinamedh.us/archives/ is the direct link to the page with the archives.

    Thank you

  4. Kristina
    Member
    Posted 4 years ago #

    I'm going to set the archives to "both" for now until you are available to look, so IE users don't have broken archives page when accessing my site. Let me know when you are ready to look and I'll switch 'em over for ya. :)

  5. scribu
    Member
    Posted 4 years ago #

    It seems to be working fine in IE 8. Are you using IE 7? (I'm not interested in debugging for IE 6).

  6. Idodoodle
    Member
    Posted 4 years ago #

    Thanks for this plugin.

    I installed it on one of my sites using the "Nature's Highlight" theme and it looks lovely in FF and IE.

    My other site uses the theme "Atahualpa." When I select "fancy" a tiny gray wheel appears and turns and turns and turns.

    Could I have an incompatible theme?

    Another difference between the two sites is that the first has less than 100 posts and the second has over 400.

    I hope this information helps as you develop this plugin. I look forward to any suggestions you might have.

    Sincerely,

    Laine

  7. scribu
    Member
    Posted 4 years ago #

    Laine, try the development version of the plugin.

  8. buckmajor
    Member
    Posted 4 years ago #

    Nice plugin, I finally got my one working, only cause the readme.txt file said 'wp_footer()' instead of '<?php wp_footer(); ?>', as MOV mentioned.

    Apart from that, good plugin.
    CHEERS :)

  9. Idodoodle
    Member
    Posted 4 years ago #

    Dear Scribu:

    Thanks so much for the prompt reply. I installed the development plugin with no success and switched around themes with no success.

    What did work was deactivating all plugins, setting Smart Archives Reloaded to "fancy," activating it, then activating each plugin one by one.

    Now everything works and looks great. Thanks again.

  10. scribu
    Member
    Posted 4 years ago #

    @buckmajor: Readme has been updated.

    @Idodoodle: Glad to hear you sorted it out.

  11. buckmajor
    Member
    Posted 4 years ago #

    Too easy thanks.
    Lastly, um are you able to help me edit the h2 tag '<h2 class="month-heading">' and '<span class="month-archive-link">(View complete archive page for October 2009)</span>'?

    I'm trying to change the h2 tag to h4, but can't find the correct file to make these changes. I had a look on the 'smart-archives-reloaded.php', and made the changes from there, but it still was the same (h2 tag) on the source code.

    Any suggestions?

    Thanks in advance

  12. scribu
    Member
    Posted 4 years ago #

    I'm trying to change the h2 tag to h4, but can't find the correct file to make these changes. I had a look on the 'smart-archives-reloaded.php', and made the changes from there, but it still was the same (h2 tag) on the source code.

    You have to clear the cache. You can do this by changing a setting from the settings page.

  13. buckmajor
    Member
    Posted 4 years ago #

    YES! I got it going. I changed the settings in the plugin settings and it updated instantly.

    Cool! Thanks for that.
    Like I said before, this is awesome plugin and easy to use ;). My site is almost finished, so I will leave a link once its completed.

    CHEERS :)

  14. Kristina
    Member
    Posted 4 years ago #

    I ended up getting Fancy archives to work, because I noticed that WordPress had inserted <code></code> around the shortcode, which IE wasn't very happy about. Simply removed it, kept it in HTML view before pressing update page, and voila! Works great!

    view it in action

  15. Kristina
    Member
    Posted 4 years ago #

    I'm having problems with the fancy CSS. I know this is probably not in the scope of your plugin support, but I can't figure out what in my CSS i overriding the SAR css...is there something I can do to fix this?

    Also: Internet Explorer isn't hiding the panes of the month that aren't selected, it's showing them all as a list

    see what's going on here (try in both IE and FF if you can)

    Thanks! Loooooooove this plugin!

  16. scribu
    Member
    Posted 4 years ago #

    You can use Firebug Lite to see what CSS is being applied to each element.

  17. Kristina
    Member
    Posted 4 years ago #

    Thanks.

    What about the IE vs. Firefox issue?

    Another question: how do I create a separate shortcode format (in addition to the [smart_archives] I have in my archives page right now) that lists the categories? Would it be something like [smart_archives format=list list_format=%category_link%]?

  18. scribu
    Member
    Posted 4 years ago #

    Yeah, your example could work. However, it would be more efficient to use wp_list_categories() directly. Please open a separate topic for that, as it's not related to this plugin.

    For the non-hiding tabs in IE, I'll have a look.

  19. Kristina
    Member
    Posted 4 years ago #

    Have you had a chance to check out the non-hiding tabs yet? Thanks very much for your help!
    http://www.prettyshinysparkly.com/archives

  20. scribu
    Member
    Posted 4 years ago #

    Version 1.8.3 should solve the problem in IE.

    It was a simple typo: <did> instead of <div> :)

  21. shannen38
    Member
    Posted 4 years ago #

    Hi. I have installed version 1.8.3. Having trouble styling the colors to suit my theme. I went under both fancy-archives.css and fancy-archives.dev.css and played around with it. But no changes I do seem to be updated. I've cleared the cache also in the settings. Is it something I'm missing?

    In particular, I'm trying to change the default color black for current month and year to something else. Coz my background is black.

    Any help will be appreciated. Thanks.

  22. scribu
    Member
    Posted 4 years ago #

    shannen38, here's how to change the CSS without modifying the plugin files:

    1. Download the development version (1.9a4)

    2. Add this code to your theme's functions.php file:

    add_filter('smart_archives_css', create_function('', 'return false;'));

    3. Copy everything from /inc/styles.dev.css into your theme's style.css file.

    4. Change the CSS in your theme's style.css file, as needed.

Topic Closed

This topic has been closed to new replies.

About this Topic