WordPress.org

Ready to get started?Download WordPress

Forums

Simple Share Buttons Adder
[resolved] Plugin slows down site (11 posts)

  1. MrMartinH
    Member
    Posted 1 year ago #

    Hi there,

    I first like to say I really like this plugin. There is only one problem that makes this plugin unfortunately useless to me: it really really slows down my site.

    I have been testing it for over a day, and at first I didn't understand why my website was extremely slow, till I found out it was your plugin causing the trouble. I'm talking about a slowdown of between 5 to 10 seconds of loading time for a simple page containing nothing more then text.

    I am not sure why it is slowing my site down. I tried disabling the counters you recently added, but that did not solve it. I embedded the code in my template files, so it shows up where I want, so I thought that might be it. But removing it and using the shortcode instead also did not solve the problem.

    I really dislike it because I really like the plugin, but this way I can not use it. I hope you can find a fix for this.

    http://wordpress.org/extend/plugins/simple-share-buttons-adder/

  2. David Neal
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Martin,

    Could you please provide me with a link to a page that you are experiencing this problem on?

    I'd really like to take a look at the individual elements of the page to determine the root of the problem.

    Thanks,

    David

  3. MrMartinH
    Member
    Posted 1 year ago #

    Here is the link: http://www.3dinyourhands.nl/lanceerkorting/ (the website is in dutch).

    I have the plugin deactivated now because I don't want to scare off my visitors.

    Greets

  4. David Neal
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the link. Would you be happy to reactivate it for a few minutes so I can take a quick look?

    I'm here ready and can let you know once I've taken a quick look?

    Thanks,

    David

  5. MrMartinH
    Member
    Posted 1 year ago #

    Ok I have enabled them.
    Must not that sometimes the site does appear more quickly, but most of the time it doesn't. For example after cleaning your browsers cache so it has to reload the entire site, which will then take too long (long enough for any visitor to just close the site)

  6. David Neal
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for doing that. I've reloaded the page quite a few times and monitored the results.

    The full page and it's content is displaying in just over a second for me, 1.15 on average, this includes the buttons and the page content. Pretty good considering the counters are included in this time!

    The real problem seems to be around the unsuccessful loading of images that your theme are calling upon, the repeat offenders are:

    seperator.png
    top.png

    http://ge.tt/2hloTgf/v/0

    As you can see it continued looking for seperator.png for over 21 seconds before aborting.

    Hope this helps, it seems like a theme related issue to me.

    Thanks,

    David

  7. MrMartinH
    Member
    Posted 1 year ago #

    Hi David,
    I'll take another critique look at my theme, as according to your image, the site is looking for seperator.png on my local machine. So that might be the issue.

    I would like to point out, however that I used the p3 plugin to measure what plugin gave the most trouble, and it pointed to yours. That might however have to do with the same problem you where struggling with.

    I'm going to look into it, and let you know the results. Thank you for your time and help. Much appreciated.

    Greets

    PS: What program have you use to monitor the website like that?

  8. David Neal
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    No problems at all.

    I'm pretty confident it's not my plugin causing the problem, it may well have an impact on load time, but next to none compare to most pages. Presumably this plugin you used doesn't check for the theme's impact?

    Thanks, do let me know how you get on.

    I am using Firebug, an extension to Mozilla Firefox, very very handy!!

    David

  9. MrMartinH
    Member
    Posted 1 year ago #

    I have made some changes to the websites code, and did a couple of tests in different browsers. All seems to work fine now.

    Thanks again for your help.

  10. David Neal
    Member
    Plugin Author

    Posted 1 year ago #

    Excellent!

    Thanks for coming back to let me know, glad I could help :)

  11. raylightuk
    Member
    Posted 6 months ago #

    I loved this plugin, but had to remove it.
    It made my pages go from around 2 secs to taking over 10 seconds to load.
    I then installed another social media sharer app and my site went back to normal quick loading, i have no idea why but for some unknown reason your plugin caused my site to take at least 10 seconds longer to load on all pages / posts.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.