WordPress.org

Ready to get started?Download WordPress

Forums

Sliding Youtube Gallery
UPGRADE NOTICE, read this if you have problems with latest update (10 posts)

  1. webEng
    Member
    Plugin Author

    Posted 1 year ago #

    If you experience some problem in the update please let me know. You can however restore the old version (1.2.5) as the following :

    1. Deactivate the plugin if active
    2. Delete sliding-youtube-gallery in wp-content/plugins
    3. Log on into your mysql database with phpmyadmin
    4. Delete wp_syg, wp_syg_styles (wp_ is assumed as generic wordpress table prefix)
    5. Click on wp_syg_OLD_V12X (wp_ is assumed as generic wordpress table prefix)
    6. Go to operation menu and rename table wp_syg_OLD_V12X to wp_syg (wp_ is assumed as generic wordpress table prefix)
    7. Execute the query: DELETE FROM wp_options WHERE option_name like '%syg%'
    8. Execute the query: INSERT INTO wp_options (option_name, option_value, autoload) VALUES ('syg_db_version', '1.3.0', 'yes')
    9. Manually download previous version of the plugin and extract into wp-content/plugins
    10. Reactivate the plugin

    http://wordpress.org/extend/plugins/sliding-youtube-gallery/

  2. sharebrain
    Member
    Posted 1 year ago #

    When i want to add a new gallery i Get the error : Warning: Division by zero in /wp-content/plugins/sliding-youtube-gallery/engine/SygPlugin.php on line 739

  3. webEng
    Member
    Plugin Author

    Posted 1 year ago #

    Hi sharebrain, check that you have latest version 1.3.2 and that you have setted all options in general settings.Number of records displayed in pagination has to be > 0

    Check also if you have more than one video in your gallery source.

    Please, let me know

  4. sharebrain
    Member
    Posted 1 year ago #

    Hello,
    thanks for the answer.
    Its the latest version. All options are set in generel settings.
    Channel is : https://www.youtube.com/user/Trommelemi?feature=watch so there is more than one video.
    I click add gallery then i fill out all the fields. Channel feed: check, YouTube user name, Maximum Video Count I Set to 50 and I disable related videos
    Style is still empty. (When I try to create a style i get the error : syg_thumbnail_buttonopacity - %s is not between %s and %s)
    Video Format i set to normal and meta information i just need duration.

    Then i click save changes and still :

    and still : Warning: Division by zero in /wp-content/plugins/sliding-youtube-gallery/engine/SygPlugin.php on line 739

    :-(

  5. webEng
    Member
    Plugin Author

    Posted 1 year ago #

    Oh no,
    sorry you must only use the username in youtube user field:

    e.g. Trommelemi

    Don't user url https://www.youtube.com/user/Trommelemi?feature=watch

    Button opacity has to be >= 0 and <= 1.

    In other cases, (for example when you add a video or a playlist) be careful to use url that contains other options. I suggest you to use only the video or the playlist ID.

    Let me know if it works

  6. webEng
    Member
    Plugin Author

    Posted 1 year ago #

    I'm sorry, I promise to develop a more comprehensive and clear user data validation service in the next version. Let me know

  7. sharebrain
    Member
    Posted 1 year ago #

    Hello,
    no it dont work. even if i just enter the admin area -> manage style (and dont do anything) : I get an error : Division by zero in /wp-content/plugins/sliding-youtube-gallery/engine/SygPlugin.php on line 788

    And it wont save any style at all :-(

    In the "manage galleries" i enetered just the youtube username. Not the channel :-) But i still didnt work.

  8. sharebrain
    Member
    Posted 1 year ago #

    When will the next version be available ?

  9. webEng
    Member
    Plugin Author

    Posted 1 year ago #

    Could I support you by Skype?

  10. webEng
    Member
    Plugin Author

    Posted 1 year ago #

    I watched the line that raise error and as I said before $options['syg_option_numrec'] must be zero in your case.

    $this->data['pages'] = ceil($this->sygDao->getGalleriesCount()/$options['syg_option_numrec']);

    The option $options['syg_option_numrec'] should be valorized with your Number of records displayed field in the Plugin admin settings fieldset.
    Check this value is not equal to zero then try to change this value again with a newest and try again.

    Let me know, Luca

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic