WordPress.org

Ready to get started?Download WordPress

Forums

Slideshow
[resolved] Warnings: TheCartpress and Post Views (11 posts)

  1. anyapisze
    Member
    Posted 2 years ago #

    I get the following warnings after activating the plugin:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'SlideshowWidget::registerWidget' was given in /wp-includes/plugin.php on line 403

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /wp-includes/plugin.php:403) in /plugins/thecartpress/TheCartPress.class.php on line 767

    Warning: Cannot modify header information - headers already sent by (output started at wp-includes/plugin.php:403) in /plugins/post-views/post-views.php on line 114

    Any help would be appreciated. Thanks!
    Mpisze

    http://wordpress.org/extend/plugins/slideshow-jquery-image-gallery/

  2. Stefan Boonstra
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Mpisze,

    I've been trying to find the error you were getting, but wasn't able to reproduce it.

    My first guess would be that you're on a server that runs an older version of PHP (PHP 4), that doesn't support the slideshow plugin. Although that didn't seem logical beacuse the warning isn't thrown at the point I would have expected it to in that case.

    So I went to look on some forums to see if more people had the same problem that you're having. Most people were speaking of a piece of code in the theme itself that might cause this warning to be thrown.

    Do you have the most recent version of WordPress?

    Regards,
    Stefan

  3. anyapisze
    Member
    Posted 2 years ago #

    Hi Stefan,

    thanks for your reply. I deactivated post-views and TheCartpress plugins, and 2. and 3. warnings disappeared.

    I have WP 3.4.1 with Weaver II 1.1.3 and PHP 5.2.17.
    So there is a conflict with Weaver or TheCartpress?

    Thanks again.

    Mpisze

  4. Stefan Boonstra
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Mpisze,

    To test your situation I downloaded and activated Post-View, TheCartPress, WeaverII and Slideshow, but I didn't get any errors.

    Also, there's nothing wrong with the version of PHP you're on.

    You were able to activate the Slideshow plugin without any warnings after disabling Post-View and TheCartPress?

    Regards,
    Stefan

  5. anyapisze
    Member
    Posted 2 years ago #

    No, I get this warning:

    call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'SlideshowWidget::registerWidget' was given in /wp-includes/plugin.php on line 403

    I can't figure out what is wrong.

  6. anyapisze
    Member
    Posted 2 years ago #

    Update:

    I disabled WP Photo Album Plus, and no warnings... :)
    WPPA has a sidebar slideshow widget, there is the conflict.

    Can you help with this?

    Thanks!

    Mpisze

  7. Stefan Boonstra
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for finding it, I hadn't considered the possibility of a namespace complication yet.

    The WordPress Photo Album Plus's widget uses the same class name as the Slideshow's widget so I'm going to rename the classes and release version 1.3.5. That should fix the warning.

  8. anyapisze
    Member
    Posted 2 years ago #

    Thank you very much!

  9. Stefan Boonstra
    Member
    Plugin Author

    Posted 2 years ago #

    You're welcome, version 1.3.5 is now ready to download.

  10. anyapisze
    Member
    Posted 2 years ago #

    Perfect! 5 stars :)

  11. Stefan Boonstra
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.