WordPress.org

Ready to get started?Download WordPress

Forums

Slideshow
[resolved] !slideshow_deploy! Showing up in widget (7 posts)

  1. brucecamp4
    Member
    Posted 1 year ago #

    I am using your plugin with the Graphene theme. I had a slideshow put into a header widget and everything was working correctly. However, I tried to add a new widget area via Graphene and now the header slideshow will no longer work. I instead get !slideshow_deploy! where the slideshow should be, and the slideshow that is supposed to show up in the header is displaced to where a second slideshow is supposed to be (on top of the content on the homepage). I have looked and looked but can not figure out where the problem lied. Can you assist?
    the site is http://njgroutman.com

    http://wordpress.org/extend/plugins/slideshow-jquery-image-gallery/

  2. brucecamp4
    Member
    Posted 1 year ago #

    Well, i was able to workaround that issue by using your widget (it was working without it earlier, but i really dont care how I get them on there) However, I can not have two of them on the same page as if I line one up with margin, the other follows suit. I can not get them to line up correctly. Can you assist?

  3. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    !slideshow_deploy! tag is used by the shortcode to get around WordPress auto-styling the HMTL, which broke the script for many users. This tag is filtered and replaced by a slideshow when it's been placed in a post.

    It indeed is shame that slideshows cannot be separately styled yet, especially in your case.

    You could probably style both slideshows separately by taking the custom style you added:

    .slideshow_container .slideshow_overflow{
    	margin:140px 0 0 515px;
    	position:relative;
    	overflow:hidden
    }

    And replacing it by this:

    .widget .slideshow_container .slideshow_overflow{
    	margin:140px 0 0 515px;
    	position:relative;
    	overflow:hidden
    }

    Since the header slideshow is in a widget, it's a child of the 'widget' class. You could style both slideshows separately with this technique.

    I hope that helps!

  4. brucecamp4
    Member
    Posted 1 year ago #

    That worked. Thank you very much for the help. It makes sense that it should be the child of the widget class, but I was so wrapped up in it stopping working that I didnt put thought into proper CSS.

    When you say, slideshows cannot be seperately styled yet, do you mean that you will add this in a future release of the plugin? That would be great!

    Thanks again for your assistance.

  5. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    You're welcome! I'm glad to hear that it works.

    Separately styling each slideshow will indeed be available in the next release, version 2.2. This version will probably be released somewhere in October.

  6. brucecamp4
    Member
    Posted 1 year ago #

    Looking forward to it. I have a bunch of other sites that I have built over the past few years that are going to get updated with your slideshow once I can style them individually. Great plugin.

    Thanks again and good luck!
    Cheers-
    B

  7. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    I had a little spare time this evening, so I made it possible to style each slideshow separately. If you'd like to try it out, you can find the update in the development version here:

    http://downloads.wordpress.org/plugin/slideshow-jquery-image-gallery.zip

    I hope you like it!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.