WordPress.org

Ready to get started?Download WordPress

Forums

Slideshow Gallery
[resolved] Doesn't work when wordpress is installed in sub directory (5 posts)

  1. nexe
    Member
    Posted 2 years ago #

    The thumbnails fail to render when wordpress is installed in a sub directory. Using 1.2.2.1

    To fix it. edit helpers\html.php

    change line 45 to this
    $tt_image = '<img src="' . $this -> timthumb_url() . '?src=' .rtrim(get_bloginfo('wpurl'), '/').'/'. $image;

    change line 57 to this
    $tt_image = $this -> timthumb_url() . '?src=' .rtrim(get_bloginfo('wpurl'), '/').'/'. $image;

    http://wordpress.org/extend/plugins/slideshow-gallery/

  2. nexe
    Member
    Posted 2 years ago #

    it also crashes IE

    move the preloader inside the jquery ready function.

    in views/default/gallery.php it should be

    jQuery(document).ready(function() {
    		jQuery.noConflict();
    		tid('slideshow').style.display = "none";
    		tid('<?php echo $wrapperid; ?>').style.display = 'block';
    		tid('<?php echo $wrapperid; ?>').style.visibility = 'hidden';
    		// append the spinner
    		jQuery("#fullsize<?php echo $rand; ?>").append('<div id="spinner<?php echo $rand; ?>"><img src="<?php echo $this -> url(); ?>/images/spinner.gif"></div>');
    		tid('spinner<?php echo $rand; ?>').style.visibility = 'visible';
    
    		window.onload = function() {
  3. abuseart
    Member
    Posted 2 years ago #

    Thanks for sharing the solution, nexe.

    Unfortunately, mine still doesn't work.

  4. myrakinko
    Member
    Posted 2 years ago #

    Thanks NEXE,
    It works for me!

  5. Junior Grao
    Member
    Posted 1 year ago #

    Thanks Nexe

    It Works for me too!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.