WordPress.org

Ready to get started?Download WordPress

Forums

SlideDeck 2 Lite Responsive Content Slider
[resolved] [Plugin: SlideDeck 2 Lite] Memory Size Problem (8 posts)

  1. Lane Lester
    Member
    Posted 2 years ago #

    I'm getting this from my new deck:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1245184 bytes) in /home/birding/public_html/wp-includes/class-simplepie.php on line 5416

    Lane

    http://wordpress.org/extend/plugins/slidedeck2/

  2. jamie3d
    Member
    Plugin Author

    Posted 2 years ago #

    Hi llester,
    Where does this happen? Does it happen on the manage view or on a page with a specific deck?

  3. dtelepathy
    Member
    Plugin Author

    Posted 2 years ago #

    Hi llester,
    Did you ever get this resolved?

  4. Lane Lester
    Member
    Posted 2 years ago #

    I don't know why I didn't get an email of jamie3d's question.

    The errors are seen on the manage page under "News and Updates" and "Latest Tweets."

    I just checked the site, and the errors are still there.

    I went through the steps to create a YouTube slider, clicked to save it. No feedback whether that was successful, except the window jumped to the top.

    Back to Manage Screen, and there it is! But I'm thinking, what is going to control getting only videos relevant to my niche?

    Well, I go to create a page, and a new error pops up:
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 500001 bytes) in /home/birding/public_html/wp-includes/class-snoopy.php on line 900

    class-snoopy.php is a WordPress file, so it looks like something more general is wrong. It looks like this happens only with Posts and Pages.

    Whoops, maybe not. I disabled the SlideDeck plugin, and now Posts and Pages work just fine.

    Yep, activate SlideDeck, and P&P are again broken.

    Lane

  5. kynatro
    Member
    Plugin Author

    Posted 2 years ago #

    This error will usually display itself when your web server's PHP memory limit is set too low. It looks like your current setup is configured to allocate 32MB of memory to PHP when the recommended running operation should be 128MB. I would contact your web host to ask how to configure this or if they can up the memory limit and you should be good to go.

  6. Lane Lester
    Member
    Posted 2 years ago #

    I added a php.ini for more memory, but it didn't take. I filed a ticket with the hosting company and they took care of it. I need to find out what they did.

    Anyway, it's working now, but I have either forgotten or missed something:

    How do we get content that has any connection with our niche? I made a YouTube SlideDeck, and it's displaying random stuff.

    Lane

  7. jamie3d
    Member
    Plugin Author

    Posted 2 years ago #

    Glad to hear you got the PHP error sorted out.

    For the YouTube source, you should just be able to do either a search or enter your YouTube user name.

  8. ddpweb
    Member
    Posted 1 year ago #

    Just as a sidenote. I've seen this memory issue recently on a couple different WP sites.

    There seems to be an indication that in my case, it has something to do with the theme that I'm using that requires the max PHP limit to be increased.

    Certain plugins like Pinterest, and even the WPPaginate plugins were both getting this error once the database got to be a larger size.

    I think it has something to do with how this particular theme has been programmed which is intensive to the database, and so require additional space to function with additional plugins...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.