WordPress.org

Ready to get started?Download WordPress

Forums

Slickr Flickr
"Allowed memory size" Error (7 posts)

  1. Todd Christensen
    Member
    Posted 2 years ago #

    Using your Plug-in ( great plug-in, BTW) as a way to display portfolio archive thumbnails from Flickr.

    http://www.quesinberry.com/wordpress/what

    A couple of issues. It's displaying on every page but one (scroll to the bottom). After upgrade I cant get Lightbox to function.

    And this page the thumbs are not displaying:

    http://www.quesinberry.com/wordpress/what/restaurants/

    The page links to a Flickr category that has the most images to display.

    It's giving me a rather strange error:

    "Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 23302 bytes) in /data/12/1/27/97/1190097/user/1267670/htdocs/wordpress/wp-includes/functions.php on line 1038"

    It could be there is abetter way to configure the plug-in to achieve what I'm attempting. Especially with the Lightbox error. But the memory error stumps me. I've cleared caches and all the usual trouble shooting. I checked out the functions.php file and can't seem to find anything odd there. What do you think?

    Thanks in advance for any help.

    —Todd

    http://wordpress.org/extend/plugins/slickr-flickr/

  2. Todd Christensen
    Member
    Posted 2 years ago #

    Heads up:

    I JUST disabled the faulty archive post on the page I linked to above as I have a new client reviewing some work and I don't want them to see the error.

    BTW the Lightbox error is happening only in Chrome (on the Mac) and I'm using a Slimbox2 Lightbox custom installation.

  3. Russell Jamieson
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Todd,

    The Fatal error: Allowed memory size of 33554432 is a PHP error. The page is question has tried to surpass the default limit of 32Meg.

    To fix this add the following line to your wp-config.php

    define('WP_MEMORY_LIMIT', '64M');

    The more photos you ask for on a page, the greater amount of memory is required.

    Regards
    Russell

  4. Russell Jamieson
    Member
    Plugin Author

    Posted 2 years ago #

    The Slimbox issue might be down to installing 2 versions of jQuery -

    Your page has

    <script type="text/javascript" src="http://www.quesinberry.com/wordpress/wp-includes/js/jquery/jquery.js?ver=1.6.1"></script>

    and

    <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.4.3/jquery.min.js"></script>

    My suggestion to just to install jQuery once and use the later version

  5. Todd Christensen
    Member
    Posted 2 years ago #

    Thank you so much Russell. If you come to Seattle I owe you a beer.

  6. rjsakai
    Member
    Posted 2 years ago #

    Hello, I'm having the same problem, however, adjusting the memory limit to 64MB doesn't seem to be working. I'm using the Lightbox Plus plugin also. It was working fine until today. http://chiapasproject.com/wordpress/delegations-2/2006-2/photos-2/

    Thanks very much. This is has been a very helpful plugin.

  7. Russell Jamieson
    Member
    Plugin Author

    Posted 2 years ago #

    @rjsakai, there also may be a limit in the PHP settings of 32M - this is likely defined in the php.ini - you may be able to change this yourself or if not ask your host to do this.

    The PHP memory_limit issues is discussed here

    Although this post in relating to Drupal and not WordPress, it is the same underlying PHP issue under scrutiny

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic