WordPress.org

Ready to get started?Download WordPress

Forums

SlickQuiz
[resolved] Published Quiz but don't see it on the site (8 posts)

  1. JobTraining101
    Member
    Posted 2 years ago #

    I've created a quiz using your plug-in and was able to click the "Publish" button. The status shows Green which means it's been published to the web site. But when I go to the web site, I don't see the quiz what-so-ever. Do I have to embed some code in to my pages or posts in order for it to show up?

    http://wordpress.org/extend/plugins/slickquiz/

  2. jewlofthelotus
    Member
    Plugin Author

    Posted 2 years ago #

    Hi @JobTraining101 - yes, there is a shortcode you will need to place either in a post, on a page, or in the sidebar text widget:


    [slickquiz id=X]

    Copy the above line and replace the X with the ID of your quiz (which can be found next to your quiz in the main list).

    NOTE: To put a quiz in the sidebar text widget, there is another piece of code you'll need to add to your theme. See http://wordpress.org/extend/plugins/slickquiz/installation/ for complete details

  3. rhoyt
    Member
    Posted 1 year ago #

    With your help I was able to publish the quizzes successfully 3 weeks ago. They are now gone even though the plug in is activated, is the newest and I can see the shortcode. Since then we did install a new table plugin. Here is the code http://pastebin.com/HYjm1dk5
    Thanks....Bob

  4. jewlofthelotus
    Member
    Plugin Author

    Posted 1 year ago #

    @rhoyt - It looks like there are a few javascript errors occurring on the page before the quiz is able to load. They're coming from the following files:

    aller.font.js - line 7: Cufon is not defined
    scripts.js - line 4: Cufon is not defined
    main.js - line 3: Object [object Object] has no method 'responsiveNavigation'

    You'll have to address those issues before the quiz will work.

  5. rhoyt
    Member
    Posted 1 year ago #

    My developer deleted these javascripts and I deactivated the one plug in I installed after Slickquizzes but neither caused the quizzes to reappear. Once again I captured the source code on pastebin if you would be so kind as to take another look. Thanks http://pastebin.com/SgyvVs7A

  6. jewlofthelotus
    Member
    Plugin Author

    Posted 1 year ago #

    @rhoyt - Looks like the error on line 3 of main.js is still occurring, hopefully fixing that one will get the quizzes back.

  7. rhoyt
    Member
    Posted 1 year ago #

    He moved some Java script from the third line as you recommended and that did it. Thank you very much. In your honor I will make a donation to Kiva.org......Bob

  8. jewlofthelotus
    Member
    Plugin Author

    Posted 1 year ago #

    @rhoyt - Glad to hear you got it working! And thank you for the donation, Bob, that's very thoughtful of you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags