WordPress.org

Ready to get started?Download WordPress

Forums

Sitewide (Admin) Header/Footer
[resolved] settings not saved (6 posts)

  1. Chris
    Member
    Posted 3 years ago #

    Version 0.6 saves only "Sitewide Admin Footer Content". Other settings get lost.

  2. interzis
    Member
    Posted 3 years ago #

    same to me.

    in wp_sitemeta table are missing some entries:
    shf_admin_footer_content
    shf_header_content
    shf_footer_content

    I added manually but still have bugs in php code because are not updated through admin area.

    the plugin will do it's job by adding the desired code into these entries (by phpmyadmin).

    I'll try to find some time to try to fix the php code

    regards

  3. interzis
    Member
    Posted 3 years ago #

    I think I found the problem

    To fix it, in sitewide-header-footer.php search for

    $_POST['_ and replace it with $_POST['shf_

    you should find this in 3 lines (for admin footer, for sitewide header and for sitewide footer)

  4. Chris
    Member
    Posted 3 years ago #

    seems to be working now, many thanks!

  5. interzis
    Member
    Posted 3 years ago #

    you welcome,

    please notice the admin footer is switched (by mistake) with admin header.
    you can fix this label in the <table> section, same file

    regards

  6. Philipp15b
    Member
    Plugin Author

    Posted 3 years ago #

    Should all be fixed in version 1.0 ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic