WordPress.org

Ready to get started?Download WordPress

Forums

SitePush
[resolved] login problems, mixed (3 posts)

  1. fondon
    Member
    Posted 1 year ago #

    Ok, sitepush seems to be running well, I can push the live site to the dev site, but:
    I can not log into the dev site, as it send me back to the live login. I can make changes in the live but not to dev. On the registratrion keeps sending me back to the live version.

    When at the http site, dev version, on the admin bar, refers me to the live version admin.

    I would be grateful is you can help
    Kind regards-

    http://wordpress.org/extend/plugins/sitepush/

  2. Mark Rowatt Anderson
    Member
    Plugin Author

    Posted 1 year ago #

    Have you explicitly defined the site url in your dev wp-config.php file? If not, that should do the trick. In your wp-config.php file for the dev site add something along the following lines:-

    define('WP_SITEURL',"http://dev.example.com/wp" );
    define('WP_HOME',"http://dev.example.com");

    or whatever is appropriate in your install. I would also put the equivalent lines in wp-config.php for your live and other sites too, so that wherever you are pushing from/to, WordPress always knows what the correct URL is for any given site.

  3. Mark Rowatt Anderson
    Member
    Plugin Author

    Posted 1 year ago #

    If your setup is a subdirectory multisite one, there was a bug which could cause the behaviour you describe. It should now be fixed in version 0.4.1.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic