WordPress.org

Ready to get started?Download WordPress

Forums

Site Template
cant choose template when creating new site? (8 posts)

  1. Cole Geissinger
    Member
    Posted 3 years ago #

    I used to be able to get the option to choose what template I want to use when I'm creating a site in 3.0.4 - but I just updated to the latest version (3.1.2) and the "Super Admin" section has been moved to a different location than before. Now all of that is under the "Network Admin" section.

    Everything still seems to be working but when I got to the Network Admin section and choose to add a new site I don't get the option to choose a template??

    Is this plugin 3.1.2 ready? I'd love to continue using this plugin!

    http://wordpress.org/extend/plugins/site-template/

  2. michael_porter
    Member
    Plugin Author

    Posted 3 years ago #

    Would love to add this functionality but there is no way to do it on the Network Admin Add Site screen.

    Sorry.

  3. Cole Geissinger
    Member
    Posted 3 years ago #

    I'm confused then.. how do I create a new site by choosing a template if it's not working in the "Add New Site" section? Is there another area I'm not seeing?

    That's how it used to work when there was a Super Admin box in the sidenav but everything has moved to the network admin?

    I'm just trying to figure out how to use the plugin with 3.1.2 :(

  4. Cole Geissinger
    Member
    Posted 3 years ago #

    oh ok, I see how this is working now. :)

    I haven't seen/heard of the wp-signup page. You should try including a link to that section if possible? I wouldn't have found that page with out some googling :P

  5. Cole Geissinger
    Member
    Posted 3 years ago #

    one other bug I found...

    When I deactivated the plugin it removed all of my active templates? :(

  6. darrentucs
    Member
    Posted 2 years ago #

    Hi Michael,

    Just a quick question...Im not sure if its my setup on myside but...I have a site template, setup with posts etc. Only issue is when a users selects the blog template on registration, the images I used dont get pulled through. The post text and everything is perfect, I just lose the images. Im not sure if this feature is available or not to import the images too but thought id run it by you first...

    Thank you for a superb plugin though...other than the images it works bombs!!!

  7. eMatt
    Member
    Posted 2 years ago #

    @darrentucs: Do you use WP 3.3.1? If so, how did you get the plugin running? For me, when I create a new site, I don't get the list with templates and nothing of the template is used. I even commented out that first line of the wp-activate.php (which in my opinion is very bad idea to make obligatory for the installation as it will be undone on a WP update).

  8. kristarella
    Member
    Posted 2 years ago #

    @eMatt --- The earlier posts in this thread suggest that you cannot create sites from a template from the Network Admin, you have to use the site registration page from the front-end of your site. To do that you have to enable site registrations in your Network Settings and then go to YOUR_SITE_URL/wp-register.php

    It'd be great if this was mentioned on the plugin page: not intuitive at all since WordPress networks don't have site registration from the front end turned on by default!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic