WordPress.org

Ready to get started?Download WordPress

Forums

Simply Exclude
Problem with pages (3 posts)

  1. bgunsberger
    Member
    Posted 2 years ago #

    Hi,

    I'm having a problem with 2.0.3. If I set pages to 'include only' for search then I get no posts in search results. However if I use 'exclude' mode (and invert the selection), posts work fine.

    Regards,

    Ben

    http://wordpress.org/extend/plugins/simply-exclude/

  2. bgunsberger
    Member
    Posted 1 year ago #

    I'm still getting this problem, even with the 2.0.5 update. Any news on this?

  3. pmenard
    Member
    Plugin Author

    Posted 1 year ago #

    @bgunsberger The Pages search exclude/include does work as designed. I just double checked this on my local development site.

    My setup:
    WordPress latest version
    Simply-Exclude: 2.0.5
    Theme: default TwentyEleven
    Under Simply Exclude Settings for Pages I have the following
    http://screencast.com/t/QvFqjnH5wJa

    On the Pages listing in wp-admin I've randomly selected a few pages to exclude. Works.

    Change the setting from 'Exclude' to 'Include only'. Now only checked pages are showing for the search results.

    What is your setup? You may have an issue with your theme. In the Simply Exclude Settings Pages section there is a new option for 'Query Filtering'. By default only the main loop is filtered. You might try setting this to all loops to see if your issue is resolved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic