WordPress.org

Ready to get started?Download WordPress

Forums

Simple Twitter Connect
[resolved] The blank page (8 posts)

  1. gazpachu
    Member
    Posted 2 years ago #

    The plugin it has been working fine for several months but now it's returning a blank page after sign in in Twitter.

    I've already increased the PHP memory, check the logs, check the callback url,... nothing seems to work :(

    I just get the URL with a blank page

    http://www.mywebsite.com/news/?oauth_token=CkrIcqy3Glrua4CHgbyfHi2ZEjPBXOx6tJ2pOwQVU&oauth_verifier=8VXraGYDt6uwcszrplMPHZxrcC1Gvkef59sOiIDg

    Any ideas?

    http://wordpress.org/extend/plugins/simple-twitter-connect/

  2. andrewhawkin
    Member
    Posted 1 year ago #

    I'm getting exactly the same problem .../?oauth_token=B2l38X7TWQxPViWt49mCQlMKEDF5JHtZpXW97451YPQ&oauth_verifier=QI6C9Gwtk8CXfmO7dwM72mJ01uZOBISrDQfS9hAig

    It won't load further than that blank page.

  3. mattbarnett79
    Member
    Posted 1 year ago #

    I'm having the same problem. Not sure where to start debugging this. I've switched to a simple wordpress .htaccess, so it isn't that.

    My URL is

    http://twopixel.co.uk/?oauth_token=9lBa6eHgSxXCKl805LAXkXdQWKCTyqR8Ivs3GNRUDU&oauth_verifier=gNH2y8EQUesrSLQXwh1vDGUHRygOWzeDDjdlaSf2bt0

    Which generates a blank page with minimal HTML headers.

  4. mattbarnett79
    Member
    Posted 1 year ago #

    if I turn on wp debugging, I get

    Warning: session_start() [function.session-start]: open(/var/lib/php/session/sess_g848d55kt0o1hll1auccpk9hc7, O_RDWR) failed: Permission denied (13) in /var/www/vhosts/twopixel.co.uk/httpdocs/wp-content/plugins/simple-twitter-connect/stc.php on line 33

    Notice: Undefined index: stc_req_token in /var/www/vhosts/twopixel.co.uk/httpdocs/wp-content/plugins/simple-twitter-connect/stc.php on line 189

    Notice: Undefined index: stc_req_secret in /var/www/vhosts/twopixel.co.uk/httpdocs/wp-content/plugins/simple-twitter-connect/stc.php on line 189

    Notice: Undefined index: oauth_token in /var/www/vhosts/twopixel.co.uk/httpdocs/wp-content/plugins/simple-twitter-connect/twitterOAuth.php on line 118

    Notice: Undefined index: oauth_token_secret in /var/www/vhosts/twopixel.co.uk/httpdocs/wp-content/plugins/simple-twitter-connect/twitterOAuth.php on line 118

    Notice: Undefined index: oauth_token in /var/www/vhosts/twopixel.co.uk/httpdocs/wp-content/plugins/simple-twitter-connect/stc.php on line 193

    Notice: Undefined index: oauth_token_secret in /var/www/vhosts/twopixel.co.uk/httpdocs/wp-content/plugins/simple-twitter-connect/stc.php on line 194

    Notice: Undefined index: oauth_token in /var/www/vhosts/twopixel.co.uk/httpdocs/wp-content/plugins/simple-twitter-connect/stc.php on line 196

    Notice: Undefined index: oauth_token_secret in /var/www/vhosts/twopixel.co.uk/httpdocs/wp-content/plugins/simple-twitter-connect/stc.php on line 196

    Notice: Undefined index: stc_callback_action in /var/www/vhosts/twopixel.co.uk/httpdocs/wp-content/plugins/simple-twitter-connect/stc.php on line 199

    Notice: Undefined index: stc_callback in /var/www/vhosts/twopixel.co.uk/httpdocs/wp-content/plugins/simple-twitter-connect/stc.php on line 204

    Warning: Unknown: open(/var/lib/php/session/sess_g848d55kt0o1hll1auccpk9hc7, O_RDWR) failed: Permission denied (13) in Unknown on line 0

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php/session) in Unknown on line 0

  5. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 1 year ago #

    Warning: session_start() [function.session-start]: open(/var/lib/php/session/sess_g848d55kt0o1hll1auccpk9hc7, O_RDWR) failed:

    That is your problem.

    This plugin requires that PHP session support be available and working. In your case, it appears that the session support isn't setup properly on your server.

    If you have the ability to use a custom php.ini file (most shared hosts offer this to a limited extent), then you can create a directory in your hosting account called something like /tmp or whatever, and then edit the php.ini to set the sessions.save_path value to that directory. This will give the sessions a place to be created.

    A future version of STC may remove the need for sessions.

  6. mattbarnett79
    Member
    Posted 1 year ago #

    Excellent thanks! I will have a go at getting the session support configured.

  7. mattbarnett79
    Member
    Posted 1 year ago #

    I edited stc.php at line 32 and added ini_set()

    function stc_init() {
    
      ini_set ('session.save_path', '/var/www/vhosts/twopixel.co.uk/.somefolder');
    
    ...

    Sign in for comments is now working (which is what I wanted)

    Thanks again for the help.

  8. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 1 year ago #

    Don't edit the plugin. Put that code into your wp-config.php file instead, right at the top of the file.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.