WordPress.org

Ready to get started?Download WordPress

Forums

Simple Twitter Connect
[resolved] PIN for Twitter redirect (12 posts)

  1. djbrock
    Member
    Posted 2 years ago #

    The plugin is working fine up to the point that it gives me a PIN number and tells me to go back to the site to use it. I don't know how to redirect it and would rather skip that step entirely if possible.

    http://wordpress.org/extend/plugins/simple-twitter-connect/

  2. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 2 years ago #

    It shouldn't give you a PIN at all. This means that you set up your twitter application wrong. Go back to the Twitter application, and put in the Callback URL properly.

  3. Manuel Schmalstieg
    Member
    Posted 2 years ago #

    Same issue here. Either we did some non-obvious mistake during setup, or Twitter has changed something.

    For instance, the plugin told me to setup the application as "browser" type, but I have not seen that option. It's not offered anywhere in the Twitter application settings.

    About the callback URL, what should that be? The URL of the WP site?

    EDIT: Answering my question, it seems that this worked, entering my WP site URL into the "callback URL" field allowed the plugin to authenticate itself.

  4. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 2 years ago #

    Yes, twitter has changed their developer tool a couple times since I wrote those instructions.

    Putting in the callback URL is enough to make it work properly.

  5. djbrock
    Member
    Posted 2 years ago #

    When I used the domain URL plus the Access Token it worked.
    http://yourdomain.com/accesstoken

  6. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 2 years ago #

    You don't need to add "accesstoken". Just the normal Site URL is all that is needed for the callback URL.

  7. djbrock
    Member
    Posted 2 years ago #

    That's what I did the first time and it gave me the PIN message.

  8. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 2 years ago #

    It should only give you the PIN message if you leave the Callback URL field blank.

  9. mkimitch
    Member
    Posted 2 years ago #

    Very helpful, thanks!

  10. stonefree
    Member
    Posted 1 year ago #

    Hi Otto or djbrock,

    I'm having the same issues with PIN as djbrock, but I'm not seeing a Callback URL field anywhere. Can you elaborate?

    To summarize :
    1) I click "Sign in with Twitter" on your plugin (0.15) settings page
    2) The "Authorize App" screen comes up
    3) After clicking authorize it gives me a PIN

  11. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 1 year ago #

    Not sure how it could be any clearer, really.

    - Go to https://dev.twitter.com/apps
    - Click your Application
    - Click the "Settings" tab
    - Scroll down and fill in the "Callback URL" field properly.

    After this, you won't get the PIN thing anymore.

  12. KreativeLabs
    Member
    Posted 1 year ago #

    Thanks Otto for the Callback URL hint, it worked!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic