WordPress.org

Ready to get started?Download WordPress

Forums

Simple Twitter Connect
[resolved] Autotweet not set to a Twitter user (14 posts)

  1. bourgogne365
    Member
    Posted 3 years ago #

    Hi,
    The STC Followers Widget does not display any follower on my website. I've read that publish settings must be set to an user, but I don't know how to do it : the publish settings display "Autotweet not set to a Twitter user".

    I tried "Authenticate for auto-tweeting", but I only get an error message "Access Forbidden".

    I've tried to create a new Twitter API, but nothing changed. Is there a particular setting to choose when I create the API ?

    (Note : when I edit a post, the "Twitter publisher - Tweet This" works).

    What can I do to set the autotweet user ?

    My website is http://www.bourgogne365.com (the widget is on the right sidebar).

    Thanks a lot

    http://wordpress.org/extend/plugins/simple-twitter-connect/

  2. First, follow the instructions in the STC settings page to setup your Twitter application, then enter the required information in the settings page.

    When that's done, check the "Automatically Tweet on Publish" box and click the "Sign in with Twitter" button next to "Authenticate for auto-tweeting."

  3. bourgogne365
    Member
    Posted 3 years ago #

    Thank you for your reply, but I really don't know where I could find these instructions to setup my Twitter application. I can't find any instruction on Otto's website, nor in the readme.txt, nor in the STC settings page (I can only put my consumer key, consumer secret, check "automatic publishing" and manage auto-publish option).

    Do you have an URL where I could find these informations ?

    Sorry again. Thanks.

  4. If this is your first time installing the plugin, the instructions should appear. They disappear after entering the info into the "Twitter Consumer Key" and "Twitter Consumer Secret" fields. If the instructions are missing, here's a transcript:

    Main Settings

    To connect your site to Twitter, you will need a Twitter Application.
    If you have already created one, please insert your Consumer Key and Consumer Secret below.

    Can't find your key?

    1. Get a list of your applications from here: Twitter Application List
    2. Select the application you want, then copy and paste the Consumer Key and Consumer Secret from there.

    Haven't created an application yet? Don't worry, it's easy!

    1. Go to this link to create your application: Twitter: Register an Application
    2. Important Settings:
      1. Application Type must be set to "Browser".
      2. Callback URL must be set to "http://www.bourgogne365.com".
      3. Default Access type must be set to "Read and Write".
      4. Use Twitter for login must be checked (enabled).
    3. The other application fields can be set up any way you like.
    4. After creating the application, copy and paste the Consumer Key and Consumer Secret from the Application Details page.
  5. bourgogne365
    Member
    Posted 3 years ago #

    Thanks,
    I've deleted the plugin AND all its settings, and then I get the instructions (they didn't appear when I simply reinstalled the plugin without deleting its settings). I've created a new API (but settings are the same than in the API I had before).

    But once again, when I click the "Sign in with Twitter" button next to "Authenticate for auto-tweeting", I get an error message "Access Forbidden".

    The "Sign in with Twitter" button links to "options-general.php" in the wp-admin folder. I verified that I have all the rights on that file, but everything was OK.

    Can I directly modify that file ? (I don't have to use several Twitter accounts). Maybe if someone can give me an example of what the plugin writes in "options-general.php"...

    Thank you

  6. Can you access /wp-admin/options-general.php in your browser? Do you get the same error?

  7. bourgogne365
    Member
    Posted 3 years ago #

    If I type in my browser
    http://www.bourgogne365.com/wp-admin/options-general.php

    it works. I don't get any error and get my general settings page.

  8. Can you take a screen shot of the "Access Forbidden" error? I'm curious if it's coming from WordPress or Twitter.

  9. bourgogne365
    Member
    Posted 3 years ago #

    The screenshot (sorry it's in French : "acces interdit" means "access forbidden" !). It says something like : You haven't got the right to get to the requested directory. Maybe there is no index document, or the directory is protected.

    The screenshot is here:
    http://www.bourgogne365.com/wp-content/uploads/2010/09/403error.gif

  10. Beurk! That's neither a WordPress nor a Twitter error. It's a server error,

    Make sure that the permissions on the /wp-admin/ directory are set to 755 and the /wp-admin/options-general.php file is set 644.

    http://codex.wordpress.org/Changing_File_Permissions

  11. bourgogne365
    Member
    Posted 3 years ago #

    I've set the dir to 755 and the file to 644 (but everything was 777 before). Nothing changed. I tried with a proxy, and with the Wifi access of my neighbors (they have another ISP) but nothing changed...

  12. I guess the next thing to do would be to contact your hosting provider about this.

  13. bourgogne365
    Member
    Posted 3 years ago #

    Thanks a lot for this advice.

    The website of my hosting provider explains that's because of a script filter, to prevent to use of scripts by spammers. I'll try to ask them to turn off that filter a few minutes, to let me fix that settings problem...

  14. Sounds like we're finally on the right track. They may be able to whitelist your domain to prevent this from ever happening again.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic