WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Simple Taxonomies] Error in the link generated by taxonomy (15 posts)

  1. bekar09
    Member
    Posted 5 years ago #

    Hi,

    I've installed WordPress 2.8 in a subfolder. After adding taxonomies to a post, links to the taxonomy tags is erroneous. A slash(/) should be preceded to the custom taxonomy. I tried to fix it by adding a slash(/) in the General Settings of wordpress, but it is saving the url without the slash.

    Help me fix it.

  2. bekar09
    Member
    Posted 5 years ago #

    I think I figured it out. It does not work with the default permalink structure.
    There's one more issue.

    Suppose if we're creating a books database using custom taxonomies where 'Author' is a taxonomy tag. In this case, can we have a separate page or post as the author' biography or will it only list everything related to the author?

    Any idea folks?

  3. Paul Bearne
    Member
    Posted 5 years ago #

    yes there is something not right here

    I have tried this with diffent permlinks pattions all seem to break

    with /recipe/%postname%/ the widget provides

    http://jessica-dennis.com/recipe/ethnicity/american/ doesn't work

    Not http://jessica-dennis.com/ethnicity/american/ which does work

  4. amygail67
    Member
    Posted 5 years ago #

    I get 'page not found' when I click on the (taxonomy) links.

    I've tried it with the default theme as well as my own (Thematic) theme.

  5. manboo
    Member
    Posted 5 years ago #

    page not found...

    what changes should be made to the themes?

  6. manboo
    Member
    Posted 5 years ago #

    en, you should update your permlinks,
    change to default
    then change back.

  7. manboo
    Member
    Posted 5 years ago #

    new question:

    how to style the taxonomy page?
    i don't want to use the default archives template.
    how to make the style different from the archives.

  8. amygail67
    Member
    Posted 5 years ago #

    Thanks manboo!
    I swear I tried that before.... Anyway - it worked today.

  9. satanas147
    Member
    Posted 5 years ago #

    @manboo
    you have to create in the default template (or your template, whatever) a taxonomy-xxx.php file (replace xxx by your taxonomy slug). you can use archive.php as basefile to customize.

    By the way, the solution for initial question would be to edit the plugin file simple-taxinomies.php, line 157, and set the rewite item as false.
    the issue is that you won't have a permalink available to reach the taxonomy page, but it works...

  10. jayminkapish
    Member
    Posted 5 years ago #

    You may need to flush rewrite rules after registering taxonomy.

    add these two lines after
    register_taxonomy( $taxonomy['name'], 'post', array( 'hierarchical' => false, 'label' => $taxonomy['label'], 'query_var' => true, 'rewrite' => true ) ); line in yoast_simple_taxonomies function.

    global $wp_rewrite;
    $wp_rewrite->flush_rules();

    These lines needed only once to flush rewrite rules. You can remove them later.

  11. sairah
    Member
    Posted 4 years ago #

    I'm having the same problem, unfortunately.

    I haven't been able to get the individual tags to lead anywhere at all. I've tried toggling between different settings but that yielded no results.

    Finally, I went into the plugin's .php file and changed the rewrite from true to false on line 157.

    I thought I'd post this in case it helps anyone out.

  12. cdmarine
    Member
    Posted 4 years ago #

    You may need to flush rewrite rules after registering taxonomy.

    add these two lines after
    register_taxonomy( $taxonomy['name'], 'post', array( 'hierarchical' => false, 'label' => $taxonomy['label'], 'query_var' => true, 'rewrite' => true ) ); line in yoast_simple_taxonomies function.

    global $wp_rewrite;
    $wp_rewrite->flush_rules();

    These lines needed only once to flush rewrite rules. You can remove them later.

    This worked for me.

  13. stevejay
    Member
    Posted 4 years ago #

    I tried the solutions offered here but still could not get the plug in to work correctly.

    Before changing the rewrite rule from true to false, I was getting the "Not Found, Error 404" message when clicking on one of the taxonomy links.

    After changing the rule, I would get an archive page ("You are browsing the archives of..."), but there would be no posts, only the message: "Sorry, no posts matched your criteria."

    Of course, at least one post must match the criteria - the one from which I clicked the link to reach the archive.

    Any ideas?

  14. jascanio
    Member
    Posted 4 years ago #

    @stevejay

    I am in the same boat as you! I have tried every solution - flushing rules, resetting permalinks, etc. - and yet cannot get the page to display properly. Have you had any luck?

  15. m.a.payne@gmail.com
    Member
    Posted 4 years ago #

    Adding:

    global $wp_rewrite;
    $wp_rewrite->flush_rules();

    per jayminkapish's instructions worked for me.

    Given that he posted 5 months ago, how hard is it for the developer to also update those 2 lines and re-release a new version?

Topic Closed

This topic has been closed to new replies.

About this Topic