WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Simple Tags (RC1.2)] Getting Fatal Error After Installing RC 1.2 (24 posts)

  1. rajivvishwa
    Member
    Posted 4 years ago #

    Getting the following error after upgrading to the new version. Any idea how I can get the previous version so that I'll remove this and install that instead.

    Fatal error: Cannot redeclare define_simpletags_path_plugin() (previously declared in /blog/wp-content/plugins/simple-tags/simple-tags.php:38) in /blog/wp-content/plugins/simple-tags/simple-tags.php on line 37

    If anyone knows the solution how to fix this, please let me know...

    Note: My PHP version is < 5

    http://wordpress.org/extend/plugins/simple-tags/

  2. frav07
    Member
    Posted 4 years ago #

    Same error!

  3. danka
    Member
    Posted 4 years ago #

    I am having a FATAL error, but it is not the same... It make the Suggest TAG to dont work. And because some reason the Dragging and JS on Dashboard and on Posting Panel does not work when SimpleTag is ON.

    WordPress version 2.9.1
    PHP version 5.2.3

  4. mzeecedric
    Member
    Posted 4 years ago #

    I can confirm this. Any solution yet? The plugin seems to be partly active in my case...

  5. tangxiaojuan
    Member
    Posted 4 years ago #

    The same error? Who can help?

  6. yats
    Member
    Posted 4 years ago #

    Yep, I get a fatal error also.

  7. Henry64
    Member
    Posted 4 years ago #

    I, too, got this fatal error message. I reverted back to version 1.6.6 and life is again great.

    WordPress version 2.8.4

  8. lifeingalicia
    Member
    Posted 4 years ago #

    Hi
    I'm a php hack so not beautiful
    Found class and function name SimpleTagsBase to be the same.
    in base.php.
    Found no instance of new class but two inherit in admin.php and client.php
    Renamed class to include underscores - Simple_Tags_Base in base.php and altered the inherit in admin and client.
    Thus the function can be redeclared - the class can be inherited -started up - no idea yet if it fully functional but looks as if.
    All these are in subfolder inc.
    Best of luck
    Martin

  9. jlancon
    Member
    Posted 4 years ago #

    Same for me : this plugin could not be installed because it caused a fatal error. WP 2.9.1

  10. france1972
    Member
    Posted 4 years ago #

    Any change to have this plugin compatible with wp? I dont know but maybe someone should take the pluing and the whole project and carry it on.

    The original developer doesnt seem to be very active on it anymore!

  11. swag
    Member
    Posted 4 years ago #

    I twice ended up revering back to Version 1.6.6 with the WP 2.9 compatibility conditional hack. Both 1.7.1 releases failed to do half of what the previous version did.

  12. Amaury Balmer
    Member
    Posted 4 years ago #

    I'm stuck with SVN WordPress.org.
    Some of you have downloaded a version of development.

    The latest stable version is 1.7.1 RC.12
    A significantly updated version 1.7.2 comes by tomorrow.

    Sorry, but you must download Simple Tags again.
    For PHP4 bugs, I seek a solution for version 1.7.2

  13. swag
    Member
    Posted 4 years ago #

    Btw, I tried the new 1.7.4.1 release. Got the same "Plugin failed to reactivate due to a fatal error." message as I did with 1.7.1 RC 1.1 and RC 1.2.

    And, as in those previous cases, I refreshed my plugins and found that it was supposedly activated anyway. But yet when I edited posts or viewed my Web site, the features it supports were still either missing or broken.

    Once again, for the third time, I reinstalled 1.6.6 with the WP 2.9 compatibility conditional hack. This is getting a bit monotonous.

  14. kndy71
    Member
    Posted 4 years ago #

    Tried today's 1.7.4.2 and I'm receiving a fatal error. The previous problem was not being able to activate it with the previous release but today's release...fatal error messages.

    I deactivated it, re-activated it. Problem only works when activating the plug in.

  15. jko
    Member
    Posted 4 years ago #

    Similar problem. Updated to 1.7.4.2 and it wouldn't re-activate - fatal error.
    Tried to install on a fresh WordPress site and same problem occurs.

  16. ninathing
    Member
    Posted 4 years ago #

    After updating this plugin (to 1.7.4.2, on WordPress 2.9.1), all of my tags and categories disappeared and all my posts showed up as untagged and uncategorized. I had to uninstall the plugin and restore a backup file to get everything to show up again, and had to manually tag and assign categories all over again. Luckily my blog is fairly new so I didn't have that many posts to fix. Either way, I won't be using this plugin again. It's one thing when a plugin fails, it's another when it screws up a whole web site.

  17. Amaury Balmer
    Member
    Posted 4 years ago #

    Tried today's 1.7.4.2 and I'm receiving a fatal error.

    Can you report an error message more detailled ?
    I try the plugin on many blogs, on PHP4, PHP5 and it's works well...

  18. Amaury Balmer
    Member
    Posted 4 years ago #

    ninathing

    Simple tags use default tag API on WordPress. You older version are which version ? Before 2.3 ?

  19. alou
    Member
    Posted 4 years ago #

    Still getting a fatal error also.

  20. swag
    Member
    Posted 4 years ago #

    This is turning into a form letter. Generalissimo Francisco Franco is still dead. Yes, this plugin still fails.

    So I tried the new 1.7.4.2 release. Got the same "Plugin failed to reactivate due to a fatal error." message as I did with 1.7.1 RC 1.1 and RC 1.2 and 1.7.4.1.

    And, as in all those previous cases, I refreshed my plugins and found that it was supposedly activated anyway. But yet when I edited posts or viewed my Web site, the features it supports were still either missing or broken. No tag cloud. No tag window in the editing pane.

    Once again, for the fourth time, I reinstalled 1.6.6 with the WP 2.9 compatibility conditional hack. That is all.

  21. ninathing
    Member
    Posted 4 years ago #

    I was running WordPress 2.9.1 + the previous version of Simple Tags. It happened when I upgraded Simple Tags to the newest version. I never ran WP 2.3 or anything like that at all - I installed WordPress last December and I've kept it and all my plugins up to date ever since.

    The problem was solved by removing the plugin and restoring my posts from a backup file. Haven't had any issues since.

  22. kndy71
    Member
    Posted 4 years ago #

    Hopefully a fix via 1.7.4.3 is coming soon to eliminate the "fatal error".

  23. breakingball
    Member
    Posted 4 years ago #

    1.7.4.2 works for me. Just needed to replace the widget and its settings.

  24. Amaury Balmer
    Member
    Posted 4 years ago #

    I fix the error during the activation with WP and PHP4 on version 1.7.4.3

Topic Closed

This topic has been closed to new replies.

About this Topic