WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Simple Sidebar Navigation] _blank (7 posts)

  1. tr33m4n
    Member
    Posted 5 years ago #

    Hello there,
    Thankyou for this plugin, it has saved me so much hassle :) Just one question however, when adding links to urls is there a way to specify the target="_blank" attribute to the url?

    Cheers
    Dan

    http://wordpress.org/extend/plugins/simple-sidebar-navigation/

  2. tr33m4n
    Member
    Posted 5 years ago #

    Not to worry, I put target='_blank' in the href tags on line 43 of simple-sidenav.php

  3. tr33m4n
    Member
    Posted 5 years ago #

    ah wait, no, that just made all the links open in a new page :s any ideas?

    Cheers
    Dan

  4. Max Chirkov
    Member
    Posted 5 years ago #

    Hi tr33m4n!

    Thanks for the compliments! Right now there is no a simple way to add a target attribute to the links. I would probably have to create an additional field for it. But a quick hack could be done for the custom links. I would assume that most of the links that need to be opened in a new window would be custom or leaving your site anyway. So, just go back to the source code and insert target="_blank" in the condition for the custom links [line: 62 in the 1.3.2 version]. This way, all your custom links will be opening in a new window, but the local pages links that you select from the selection links will still open up in the same window.

    Let me know if that works for you.

  5. tr33m4n
    Member
    Posted 5 years ago #

    Hello there,
    Yeah thats basically what I tried earlier... I think I will just have to wait until its implemented as an option per link, because I have custom links, but i dont want them all to open in a new window.
    Thankyou for your help however

    Cheers
    Dan

  6. hunin
    Member
    Posted 5 years ago #

    Hi,

    I'm having an issue with SSN. I just upgraded, and now I get these errors at the top of my admin page:

    Warning: include(admin/settings.php) [function.include]: failed to open stream: No such file or directory in /home/{my info}/public_html/wp-content/plugins/simple-sidebar-navigation/simple-sidenav.php on line 10

    Warning: include() [function.include]: Failed opening 'admin/settings.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/{my info}/public_html/wp-content/plugins/simple-sidebar-navigation/simple-sidenav.php on line 10

    I'm running WP 2.7.1. I tried deactivating and reactivating the plugin. Any idea what could be causing it?

  7. hunin
    Member
    Posted 5 years ago #

    Sorry, wasn't trying to threadjack here. Please delete above; I opened a thread for my issue.

Topic Closed

This topic has been closed to new replies.

About this Topic