WordPress.org

Ready to get started?Download WordPress

Forums

Simple Nivo Slider
[resolved] Slider Not Loading (4 posts)

  1. feisthammel
    Member
    Posted 3 years ago #

    Sort of an odd situation. At first I was concerned that it was a problem with loading two copies of jQuery, but I resolved that and my issues persist.

    I tried several Nivo Sliders and liked this one the best, but it only works when I have Nivo Slider for WordPress active at the same time.

    With both plugins active, Simple Nivo Slider uses the CSS from Nivo Slider for WordPress and possibly JS resources as well, and it functions beautifully. Once I deactivate Nivo Slider for WordPress, however, it breaks. The first problem is that it displays in a div with 0 height. I tweaked the CSS to fix that issue, however, and now all I'm getting is the loading gif.

    So the problem, as far as I can tell, is that Simple Nivo Slider isn't loading the featured images properly unless Nivo Slider for WordPress is active. That's bizarre, though, because part of the reason that I don't want to use Nivo Slider for WordPress instead is that it doesn't even call featured images.

    Obviously, the basic issue is that Simple Nivo Slider isn't loading my featured images and is stuck on the loading gif. I'm just extremely confused because it functions normally in the presence of another superfluous plugin.

  2. feisthammel
    Member
    Posted 3 years ago #

    Apparently I botched the link to Nivo Slider for WordPress. At any rate, I'm still having the problem. Hoping there's a better solution than trying to juryrig a working Simple Nivo Slider installation with scavenged parts.

  3. feisthammel
    Member
    Posted 3 years ago #

    So apparently, the issue was that jquery.nivo.slider.js wasn't being called. It doesn't appear in the source of my website with a standard install of Simple Nivo Slider. simple-nivo-slider.php only includes wp_enqueue_script('nivo-slider', plugins_url('/nivo-slider/jquery.nivo.slider.pack.js', __FILE__), array('jquery')); in the scripts.

    I added wp_enqueue_script('nivo-slider', plugins_url('/nivo-slider/jquery.nivo.slider.js', __FILE__), array('jquery')); but it still wasn't appearing properly on the site. I checked the source again and it never appeared in my head.

    When I added jquery.nivo.slider.js to my theme directory and added <script type="text/javascript" src="<?php bloginfo('template_directory'); ?>/jquery.nivo.slider.js"></script> to the head, it works perfectly.

    I have no idea what to make of it all, but it works now, so I guess I'll count my blessings.

  4. SRD75
    Member
    Posted 2 years ago #

    Tried adding /wp-content/plugins/simple-nivo-slider/nivo-slider/jquery.nivo.slider.js manually myself (as it wasn't there before) but the slider div is still empty.

    I am not using any other slider plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic