WordPress.org

Ready to get started?Download WordPress

Forums

Simple Local Avatars
[resolved] avatar not showing on author page (5 posts)

  1. airujo
    Member
    Posted 1 year ago #

    hi,

    i have a problem where the author's avatar doesn't show up on the author page, e.g. http://suited.myomnipod.com/author/leighann. i enabled avatars in the discussion settings. any help is appreciated!

    thanks!

    http://wordpress.org/extend/plugins/simple-local-avatars/

  2. airujo
    Member
    Posted 1 year ago #

    i posted this on another forum and was able to fix it.

  3. eezarthegreat
    Member
    Posted 1 year ago #

    Hi there,

    Would you share how did you solved this?

    Thanks,
    e

  4. airujo
    Member
    Posted 1 year ago #

    i forgot that i used a different author page than the page that comes with wordpress by default. you need this line in your code to show the avatar:

    <?php echo get_avatar( get_the_author_meta( 'user_email' ), apply_filters( 'twentyeleven_author_bio_avatar_size', 130 ) ); ?>

    note, the size of 130 is specific to my design, you can change that to whatever you need it.

    also, i found out the hard way (meaning trial and error for quite a while) that in order for the avatar to show, you need to associate it with an article, otherwise you will only see whatever default avatar you set in the 'settings/discussion'.

    i hope this helps!

  5. eezarthegreat
    Member
    Posted 1 year ago #

    Hi airujo,

    Thank you for that :) will try get it going.

    Much appreciated,
    e

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.