WordPress.org

Ready to get started?Download WordPress

Forums

Simple Lightbox
[resolved] Next/Previous buttons appear funny (6 posts)

  1. sunhawk
    Member
    Posted 2 years ago #

    In Firefox and Chrome, when I hover my cursor over the area where the Previous and Next buttons appear, the Previous one appears to drop down from the top left corner and the Next starts at the top of the image in the center and zings quickly into place where it should be. The buttons themselves function fine but the literally moving across the lightbox area is obviously not supposed to happen, the buttons are just meant to appear in place without starting somewhere different. Is there a way to fix this bug? Thanks!

    http://wordpress.org/extend/plugins/simple-lightbox/

  2. Archetyped
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    Can you provide a URL that exhibits the issue you're experiencing?

  3. sunhawk
    Member
    Posted 2 years ago #

    Sorry for the delay, I set up a demo site to show you, the lightbox gallery on this site shows the same effects:

    http://indexmedia.ca/html/christinetest/gallery

  4. Archetyped
    Member
    Plugin Author

    Posted 2 years ago #

    It appears that your site's theme applies CSS3 transitions globally to all links on the page (including links in the lightbox). You can confirm this by switching your site to the default WordPress theme and testing whether the nav buttons in the lightbox are still animated (they should not be).

    A future update of SLB will include additional hardening to counteract such issues, but you may also want to contact the theme's developer to request that they include more specificity for such CSS rules as it affects all other content on the site (e.g. widgets, plugins, etc.).

  5. sunhawk
    Member
    Posted 2 years ago #

    Thanks for the response! I just tested your theme notion by switching to one of the default WP themes and it does appear you are correct that the theme is affecting the lightbox.

    Do you have any thoughts what specific tags in the CSS would make that sort of bug appear?

    I can tinker with the theme's CSS, I am actually working with a set of themes I got as part of a developer's package and I am testing now whether all of them have that button bug, at least one in the set doesn't have the bug but I am going to leave my test site for now on another theme that does have the bug too.

    I have a thought that the CSS in question is a part of some of the package themes and not others, but hopefully it's the same tag or code that's causing the bug that appears identically in some of the packaged themes.

    Thanks again for your help :)

  6. Archetyped
    Member
    Plugin Author

    Posted 2 years ago #

    /themes/organic_shop/style.css

    a, a:link, a:visited {
    	color: #151515;
    	text-decoration: underline;
    	transition: background .25s, color .25s;
    	-moz-transition: background .25s, color .25s;
    	-webkit-transition: background .25s, color .25s;
    	-o-transition: background .25s, color .25s;
    	}

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic