WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Simple Google Sitemap] Memory Exhausted (12 posts)

  1. jcwinnie
    Member
    Posted 4 years ago #

    The following error message appears when an entry is posted:

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 544974 bytes) in /home/jcwinnie/public_html/wordpress/wp-content/plugins/simple-google-sitemap/simple-google-sitemap.php on line 279

    http://wordpress.org/extend/plugins/simple-google-sitemap/

  2. Jonathan Dingman
    Member
    Posted 4 years ago #

    It seems your web host hasn't allowed you enough memory.

    Try adding this to your .htaccess file:

    php_value memory_limit 32M

  3. ixiter
    Member
    Posted 4 years ago #

    The memory_limit is already 64MB ;)
    It seems, 64 MB isn't enough for your blog. Try a value of 96MB or 128MB with jdingman's solution.

  4. jcwinnie
    Member
    Posted 4 years ago #

    Adding the parameter resulted in a 500 Internal Server Error.

    Removal of the offending line, resulted in a reactivated site, yet a blank screen.

    Repair of all database files resulted in a working site again.

  5. jcwinnie
    Member
    Posted 4 years ago #

    Google Webmaster Tools
    Error: The last attempt at downloading the Sitemap failed. The details below are representative of the last successful download. Resubmit?

    URLs in Sitemap Submitted Downloaded
    Sitemap Total: 3,132, Indexed: 3,132

    Oct 12, 2009 – Error Oct 14, 2009

    Sitemap errors and warnings
    Line Status Details
    Errors -
    We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.
    Problem detected on: Oct 14, 2009

  6. jcwinnie
    Member
    Posted 4 years ago #

    Nope, rebuilding the database files failed to solve all the problems. For example, the browser was trying to open or save comment.php when I wanted to save a modified comment. So I had to re-install. The server is slow in copying the files, so it is difficult to see how much the plug-ins and widgets have been wiped out.

  7. jcwinnie
    Member
    Posted 4 years ago #

    The cPanel interface tells me it is copying the files over, though there are problems due to incomplete copying.

  8. jcwinnie
    Member
    Posted 4 years ago #

    O.K. After about 2 hrs. back to about 97% normal.

  9. ixiter
    Member
    Posted 4 years ago #

    Internal Server Error 500 may occure, when this parameter is not allowed. But it shouldnt result in that mess after removing the line again.
    I will try to find solutions for even less memory usage.

    The error msg fpor the sitemap file doesnt say that much. I have no idea what could be wrong. The generated sitemaps do follow the guidelines.

    File copying errors and problems have nothing to do with the plugin. I guess there are problems with your server or hosting provider.

  10. jcwinnie
    Member
    Posted 4 years ago #

    Talked with remote host tech support.

    I had to change the parameter in the php.ini in /public_html, then copy php.ini to every directory AND subdirectory that has php files where I wanted the change to take effect. I also altered the memory parameter of the wp-config.php file.

    The error message disappeared after all of that was done. I set all to 96MB.

  11. jcwinnie
    Member
    Posted 4 years ago #

    "Just saying," for an installation on a remote host, it would seem ill-advised to recommend adding the parameter to .htaccess

  12. ixiter
    Member
    Posted 4 years ago #

    Good that you found a way to increase the memory_limit.
    I wasnt sure if you are able to change php.ini or are allowed to use ini_set in wp-config.php, since the .htaccess soluton didnt work. So I didnt mention these ways. Thanks for your update.

Topic Closed

This topic has been closed to new replies.

About this Topic