WordPress.org

Ready to get started?Download WordPress

Forums

Simple Google Connect
[resolved] oauth2callback did not match a registered redirect URI (4 posts)

  1. OC2PS
    Member
    Posted 2 years ago #

    When I click on the login with Google button, I get the error

    Error: redirect_uri_mismatch
    The redirect URI in the request: http://www.mydomain.com/oauth2callback did not match a registered redirect URI

    The problem, I think might be that

    In my plugin settings, callback URL appears as
    http://www.mydomain.com/oauth2callback
    (with no opportunity to edit anything but the slug.

    While in Google API Access, the callback URL appears as
    https://www.mydomain.com/oauth2callback
    with no opportunity to edit anything.

    How do I reconcile the http v https difference?

    http://wordpress.org/extend/plugins/simple-google-connect/

  2. OC2PS
    Member
    Posted 2 years ago #

    My bad! I was able to edit the callback URL (including protocol) in Google API Access

  3. djzoulox
    Member
    Posted 1 year ago #

    how didt you fix it ? i am uncertain on how to do it correctley :-)

  4. trmmy
    Member
    Posted 1 year ago #

    You can use "Edit settings..." link on the right side of the "Client ID for XXX".

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic