WordPress.org

Ready to get started?Download WordPress

Forums

Simple Google Connect
[resolved] Conflict with Jetpack forms (9 posts)

  1. RavanH
    Member
    Posted 1 year ago #

    Hi Otto,

    I'd like to report a conflict between the Simple Google/Facebook Connect plugins and the Forms module provided by Jetpack.

    When either of the two Simple Connect plugins (did not test STC) is activated alongside Jetpack, the Jetpack forms are simply not rendered on page. Creating the forms and inserting the shortcode all works like normal, the result is just not visible on the front-end.

    I've also noticed that Simple Google Connect disables the (final) checkout button in eShop. I'm mentioning it here since it might be a related issue...

    http://wordpress.org/extend/plugins/simple-google-connect/

  2. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 1 year ago #

    Yep, Jetpack's Grunion forms are doing-it-wrong. I've reported the issue to the Jetpack authors, but they have yet to fix it.

    Same problem with eShop. It's broken and not compatible with SFC/SGC.

  3. RavanH
    Member
    Posted 1 year ago #

    OK, that's disappointing... To hear a 'by WordPress.com' plugin is doing_it_wrong, I mean. Will have to hope for a fix then...

    Could you please give a brief rundown on the doing_it_wrong for eShop? I've opened a thread on the eShop support forum (on quirm.net) about the issue and it would help much in getting down to the issue if you could point us in the right direction.

    Much appreciated :)

  4. RavanH
    Member
    Posted 1 year ago #

    The funny thing is that one some sites running both SGC and Jetpack, the contact form works fine, while on others the contact form does not get displayed. And for the life of me, I cannot figure out why this would behave differently on different sites... Tried deactivating all other plugins and even setting all plugin options exactly the same, but it remains a mystery.

  5. elfin
    Moderator
    Posted 1 year ago #

    Missed this one before, yes eShop is doing it wrong - it will be remedied at some point in the future, sadly not short term.

  6. RavanH
    Member
    Posted 1 year ago #

    Hurray, the issue is resolved in Jetpack 2.0 ...

    And I saw an eShop update passing by but have not tested that in conjunction with Simple Google Connect yet. Rich, is there a patch for this in the new eShop?

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    Not that I'm aware of but I'll ask Rich to confirm this.

  8. elfin
    Moderator
    Posted 1 year ago #

    nope not as yet - the fix requires me to change the flow in my plugin - so not a quick job. Not forgotten, just not possible to get done until I have spare concurrent days.

  9. RavanH
    Member
    Posted 1 year ago #

    OK, thanks for letting me know. I completely understand. I'll refrain from activating the two on the same site for now, no problem ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic