WordPress.org

Ready to get started?Download WordPress

Forums

Simple Full Screen Background Image
[resolved] Plugin not working in IE9 (7 posts)

  1. stefgdbd
    Member
    Posted 1 year ago #

    I am using this plugin on my site http://www.a-gradecigars.com and when I check the site in IE9 the background image is showing up below my website content instead of behind it as a background image. Is there a quick fix I can add to my stylesheet?

    http://wordpress.org/extend/plugins/simple-full-screen-background-image/

  2. Looks like the problem is due to a lot of improperly laid out HTML tags. Are you the site developer?

  3. stefgdbd
    Member
    Posted 1 year ago #

    I did custom code the WP theme from a blank theme template. Can you give me some more insight as to what is incorrect on the code?

  4. The entire page is being wrapped with the #header-wrap div, so looks like you're missing a closing /DIV tag.

  5. StefExakt
    Member
    Posted 1 year ago #

    I have double checked my closing divs and all divs seem to have appropriate closing tags. I even rearranged and placed the "header-wrap" closing div within different places (header.php, home.php, footer.php) to see if that made a difference, but it did not.

    The background image looks fine in Safari and Firefox. However, in IE9 the background image is showing up below the website content instead of behind it still.

    Any other recommendations?

  6. StefExakt
    Member
    Posted 1 year ago #

    My apologizes, it seems like it is not your plugin but my page templates that are not displaying correctly in IE9.

    I am attempting to fix the site in IE9 with an ie stylesheet. After fixing some of the display issues and reactivating the simple background plugin, the background image is still showing up underneath the website content.

    For now I am just going to deactivate the plugin and manually add in a background image (that doesn't resize to the browser window).

    If you happen to have some suggestions for resolutions on how to get your plugin to work with my site in IE, I am open.

    Thanks,

  7. I would suggest ensuring you have correct display in IE and then reactivating the plugin. The way the plugin displays the images is by simply placing the image behind the site contents, so as long as your HTML structure is fine and the layouts aren't broken, it should all work fine.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.