WordPress.org

Ready to get started?Download WordPress

Forums

Simple Footnotes
Unwanted space before note in post text (4 posts)

  1. justderek
    Member
    Posted 3 years ago #

    Hi Andrew -- thanks for making this plugin. Very clean, no-muss-no-fuss. :)

    There is just one little tiny thing: the footnote numbers were appearing in my text with an extra space before them that I don't want.

    Example (number sign indicates the linked, superscripted footnote number):

    Lorem ipsum.[ref]My note, etc.[/ref] Blah blah blah, and so forth.
    produces

    Lorem ipsum. # Blah blah blah, and so forth.

    I fixed this by changing the beginning of line 75 of simple-footnotes.php from this:
    return ' <a class="simple-footnote"
    to this:
    return '<a class="simple-footnote"

    I'm aware, however, that this change will be wiped out by an update of the plugin. I don't know if you put the leading space before the inline citation number there on purpose.

    My humble request is that if you prefer to leave it as-is by default, could there be an option for the user to eliminate the leading space?

    Thanks again -
    Derek

    http://wordpress.org/extend/plugins/simple-footnotes/

  2. Frank P. Walentynowicz
    Member
    Posted 3 years ago #

    I'll second that. It is a standard that footnote marker follows a word immediately. Another thing is that these markers could be more pronounced ( bigger or something ). I could hardly find them applied to paragraphs of lorem ipsum.

    Very nice and clean.

    Frank

  3. Andrew Nacin
    Lead Developer
    Plugin Author

    Posted 3 years ago #

    I don't have much of an issue with removing the space. I think I did it for readability purposes initially. Going to come up with a way to template this in a new version soon.

  4. justderek
    Member
    Posted 3 years ago #

    Great -- thanks, Andrew!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic