WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Simple Facebook Connect] SFC - Comments (14 posts)

  1. Tifa
    Member
    Posted 4 years ago #

    Hi,

    In the SFC - Comments, I dont see a tab or where i can change settings.. Also based from the plugin screenshots, I dont see a "connect with facebook" button just under the "leave a reply". Im not sure why.

    thanks in advance

    http://wordpress.org/extend/plugins/simple-facebook-connect/

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    There is no settings page for the comments plugin, as there's nothing to configure.

    There are instructions in the readme.txt file that explains how to modify your comments form to show the button and such.

  3. Tifa
    Member
    Posted 4 years ago #

    ok thanks, i have configured it correctly. So if they click on the "connect with facebook" they can login using their facebook account and comments will show up in wordpress?

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    That's the point of the comments plugin, yes. :)

  5. Tifa
    Member
    Posted 4 years ago #

    thanks but after i put on my facebook email and password, the pop-up just goes to homepage and im not logged into facebook. (of course i made sure i logged out of our wordpress admin first so im like a new visitor)

    Also can you please see my other problem too?
    http://wordpress.org/support/topic/344049?replies=3

    thanks

  6. Tifa
    Member
    Posted 4 years ago #

    btw, never mind about my other problem coz its fixed..

    now my problem is that when i click the "connect with facebook" button, it would have a pop-up window right? asking for email and password for facebook.

    But after i click on "connect" the pop-up window goes back to homepage.. and i need to close it and refresh the current page and then click on the "connect with facebook" button again just to make it work.

    I was wondering if I can make the pop-up window close after i click on "connect" then refresh the current page.

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    When the popup closes, the page should auto-refresh or otherwise update. If it's not, then you have some form of problem with the javascript not working on your site correctly. Try disabling other plugins which might be interfering.

  8. Tifa
    Member
    Posted 4 years ago #

    ok i have disabled all plugins and still the same problem as above.. close pop-up refresh page, then press "connect with facebook" again just to make it work.. im using a "facebook theme"

  9. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    Well, I'd need to know the page URL in order to see the problem for myself.

  10. trumanews
    Member
    Posted 4 years ago #

    Hi Otto, great plugin, all seems to work fine!

    Just a problem: when I logout it redirects to a specific article (I don't know why that one) and not on the opened for comments..

    Can you have a possible explanation?

    Thanks!

  11. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

  12. Tifa
    Member
    Posted 4 years ago #

    Ok here is a post:
    http://www.yogabodynaturals.com/8020yoga

    Ok I updated to latest wordpress as well as updated the SFC-Comments.. The pop-up still does not close. But now I only need to refresh the page and im in. Unlike before, I have to click the "connect with facebook" for the second time.

    Also i changed the theme to "default". But its still the same

    thanks

  13. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    mardie: You have the wrong base domain configured in the facebook application. Capitalization matters!

    The Facebook Connect cross-domain receiver URL (http://www.yogabodynaturals.com/wp-content/plugins/fbconnect/xd_receiver.htm#fname=_opener&%7B%22t%22%3A3%2C%22h%22%3A%22fbCancelLogin%22%2C%22sid%22%3A%220.490%22%7D) must be in the same domain or be in a subdomain of an application's base domain (www.YogabodyNaturals.com). You can configure the base domain in the application's settings.

    Notice that "www.YogabodyNaturals.com" is not the same as "www.yogabodynaturals.com".

    You also seem to have some kind of extra code in your theme which is coming from an "fbconnect" plugin. That plugin is not compatible, deactivate it and remove any of its code from the theme.

    You cannot use more than one Facebook Connect plugin. That's why I made this one modular, so that addon plugins can be simple to use and create without having this sort of conflicting code.

  14. Tifa
    Member
    Posted 4 years ago #

    ok, i didnt know that capitalization matters.. anyway it worked!.. i just changed the capital letters in the application setting, and now the plugin works fine..

    And i will deactivate other "facebook plugin" i have tested coz im satisfied with this one

    thanks again!

Topic Closed

This topic has been closed to new replies.

About this Topic