WordPress.org

Ready to get started?Download WordPress

Forums

Simple Facebook Connect
Registration page is broken in WordPress (8 posts)

  1. karevn
    Member
    Posted 1 year ago #

    I installed the plugin and put my app ID and secret code, then enabled user registration, but see the next message:
    Unable to load the registration form for MS.dev. You may have previously blocked this app on Facebook. Go to your Facebook privacy settings to unblock this app. (Error: Invalid 'client_id'.) at the registration screen. Can you please fix it?

    http://wordpress.org/extend/plugins/simple-facebook-connect/

  2. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 1 year ago #

    "MS.dev"? Is this a test site of some kind? Is it live on the internet?

    Facebook and similar systems don't work on local test sites.

    Alternatively, you may have actually blocked your own Application. Did you create the MS.dev application?

  3. karevn
    Member
    Posted 1 year ago #

    I have the same problem on a web-accessible site. Or does Facebook make some kind of a callback?

  4. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 1 year ago #

    Did you create an application called "MS.dev"? Is that your app? Or do you not recognize it?

    Not enough information to debug, basically. I don't know what to tell you to do next because I don't have the problem and don't have enough details about your problem.

  5. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 1 year ago #

    Try this: Go to your App on Facebook (developers.facebook.com/apps) and check to make sure that you disabled "Sandbox Mode".

  6. karlazz
    Member
    Posted 1 year ago #

    Hi,

    Was there ever a resolution to this? I have the same problem. Sandbox is disabled, privacy is set to public. My app is not named MS.dev, it is named Stunning.

    I successfully set up SFC on another site, and I set up this site similarly except with the URL changes and new names etc, but this one does not work. This new site is 3.5, the other is not.

    Unfortunately, I have to take SFC down for now, because we want the site to go into production, so I am wondering if there was ever a resolution.

    BTW, thanks for the app!

    Cheers

  7. beyondeyes
    Member
    Posted 1 year ago #

    Hi there!

    I think i found out what went wrong - got the same "unable to blabla"-promt.

    Solution:

    Go to https://developers.facebook.com/apps/1234567890/appdetails (fill in the number of your app instead of "1234567890") and press "Submit App Detail Page".

    I bet there will be some "missing data" in your fb-app like mine, too.

    Cheerio & happy wordpressing!

  8. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 1 year ago #

    Doing a "Submit App Detail Page" should not be necessary to get your app to function. I've got several apps, and I've never submitted them for that review process.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.