WordPress.org

Ready to get started?Download WordPress

Forums

Simple Facebook Connect
[resolved] Issue with Publishing (6 posts)

  1. TheLazyCaveman
    Member
    Posted 3 years ago #

    Hi Otto,
    Killer app, but I'm having trouble publishing my posts to my FB app. I do have the "Publish to FB App" and "Publish to your FB Profile" buttons active, but when I click either, I get this box: http://www.thelazycaveman.com/wp-content/uploads/2011/02/fb_post.png

    And when I click through to FB, I get this lovely, non-descript error: http://www.thelazycaveman.com/wp-content/uploads/2011/02/fb_error.png

    Any thoughts? The rest of the plugin seems to be working fine, so it's likely on FB's end.
    My app is here: https://www.facebook.com/apps/application.php?id=139226969473478
    and my site here: http://www.thelazycaveman.com/

    Thanks!

  2. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 3 years ago #

    I'd say that you haven't set up your application properly (wrong URL) or something like that. Either that, or you put the API key and App Secret in the wrong boxes on the plugin screen or something.

    Double check through all the settings, make sure they're correct.

  3. TheLazyCaveman
    Member
    Posted 3 years ago #

    I did double check the settings and the API key, App Secret and App ID are all in the right places. The Fan box on my page is pulling data from FB, so that half of the link is working. It just seems to be that I can't push data to the app.

    Would the Canvas URL have an impact? It's set to the same page as the Site URL. http://www.thelazycaveman.com. As are the Privacy and TOS URLs. I've left the Canvas Page blank.

    What should I be seeing in that pop-up dialog box?
    Thanks Otto!

  4. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 3 years ago #

    Try taking everything off the "Facebook integration" page. That page should be entirely blank, since you're not making a canvas application here. The only thing that you should fill in is the About and Web Site pages.

  5. TheLazyCaveman
    Member
    Posted 3 years ago #

    Nothing :( . Any other ideas?

    The FB API wouldn't save any of my changes when trying to delete the Canvas URL, so I had to delete the app and recreate it. Again, the same problem, it will pull "likes" to the Fan Box, but won't push any posts.

    Thanks for your time.

  6. TheLazyCaveman
    Member
    Posted 3 years ago #

    Hey Otto,

    I don't know what changed in the past week, but all of a sudden everything started working with the publisher. Must've been something on FB's end. So consider this resolved!

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic