WordPress.org

Ready to get started?Download WordPress

Forums

Simple Facebook Connect
ie 9 compatibility (15 posts)

  1. nawak
    Member
    Posted 3 years ago #

    Hello

    the button connect with facebook is not displayed with internet explorer 9 beta, i have only a text "Connect with Facebook"

    can you fix it ?

    thank you

    +++

    http://wordpress.org/extend/plugins/simple-facebook-connect/

  2. nawak
    Member
    Posted 3 years ago #

    otto why you dont answer me ? my mesage is correct with hello thank you and +++ i don't have an answer because i'm french ? because i speak english very bad ?

    tell me why thank you

  3. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 3 years ago #

    For reference, I don't read everything every day. I do have a day job. :)

    A text-only "Connect with Facebook" usually means that your theme is missing the wp_footer() call in the footer.php file.

  4. Steerpike
    Member
    Posted 3 years ago #

    I have the same problem. Works fine in everything but IE9 Beta. I have the wp_footer() call. Any ideas? Thanks!

  5. Giorgos Sarigiannidis
    Member
    Posted 3 years ago #

    Same here...

    It only happens with IE9 beta. I tested it with IE8 and it works fine.

  6. divyabh
    Member
    Posted 3 years ago #

    Did anyone find a solution to this?

  7. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 3 years ago #

    The current solution seems to be don't use IE9 beta.

    Basically, the problem is that Facebook's Javascript code doesn't support IE9 yet. Until it does, there is no fix.

  8. ontheinternets
    Member
    Posted 3 years ago #

    FYI, I know this is not an optimum solution but if you add
    <meta http-equiv="X-UA-Compatible" content="IE=8" />
    To your head, it will force IE9 to use IE8 compatibility mode and the plugin will in fact work. It might not be optimum but for the moment it's all I have got.

  9. divyabh
    Member
    Posted 3 years ago #

    Hi ontheinternets,

    Tried adding the meta tag you've suggested. Still doesn't work!

    the site is http://www.ideabuff.com

  10. ol74eg
    Member
    Posted 3 years ago #

    Yep, it doesn't work.. any ideas?

  11. ontheinternets
    Member
    Posted 3 years ago #

    @divyabh & ol74eg, Not sure what you guys have activated. I am only using
    SFC - Fan Box Widget
    SFC - Login
    Simple Facebook Connect - Base

    I have not tried the IE8 compatibility mode stated above with anything else but I can verify it works for me in IE9. Sorry it did not work for you.

  12. divyabh
    Member
    Posted 3 years ago #

    Its working now. I am using the WP-FB Autoconnect plugin.

    You need to add the following to the header

    <meta http-equiv="X-UA-Compatible" content="IE=7" />

    IE-7 rendering seems to work!

  13. jb317
    Member
    Posted 3 years ago #

    Same issue here. Doesn't work in IE 9. Subscribing to this thread.

  14. ol74eg
    Member
    Posted 3 years ago #

    Thanks, divyabh. It works!

  15. MrVitaminP
    Member
    Posted 3 years ago #

    There seems to be some indication that this error only occurs if you're using an old version of the Facebook API: http://bugs.developers.facebook.net/show_bug.cgi?id=15397

    Would it be possible to get this fixed?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic