WordPress.org

Ready to get started?Download WordPress

Forums

Simple Facebook Connect
error publishing to facebook (4 posts)

  1. oldski
    Member
    Posted 2 years ago #

    The plugin seems to work when I'm logged into facebook as my client. But, when I attempt to publish a post when his account is logged off or when I'm logged in with mine, the publish buttons provide this error:

    API Error Code: 110
    API Error Description: Invalid user id
    Error Message: Missing user cookie (to validate session user)

    I received a green light with all three tokens in the plugin's settings. We both are admins to the fan page as well as the fb application. Any further guidance would be greatly appreciated.

    http://wordpress.org/extend/plugins/simple-facebook-connect/

  2. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 2 years ago #

    Short answer is that you can't logout of Facebook anymore. They are in the process of removing the "offline access", and while I'm trying to figure out a way to work around it, there doesn't seem to be a way to do it at the moment. Blame Facebook.

  3. Iamhere
    Member
    Posted 2 years ago #

    Hi

    I also have the same issue! Very frustrating ! So close!

    Steps taken:
    1) Verify the user's account with mobile phone:
    http://www.facebook.com/confirmphone.php

    2) Add user as an APP developer & confirm

    3) log in to WP as user - edit post, click on Publish to FB Fan Page

    Receive Error:

    API Error Code: 110
    API Error Description: Invalid user id
    Error Message: Missing user cookie (to validate session user)

  4. Iamhere
    Member
    Posted 2 years ago #

    SFC v 1.2
    WP 3.31

    OK - I think I solved this

    Follow the steps above, then:

    1) make the user Admin in WP
    2) Log in to WP as your user
    3) navigate to settings > simple facebook connect
    4) GRANT SFC Permissions button
    5) go to edit post, test Publish to FB ....

    It worked for me.

    Then I changed the user from admin to Editor role and it still works, so all good so far !!

    Then I deleted the user as an admin from the FB app - still works :-) Yipeee

    Observation: The user must be logged in to FB before posting to wall, otherwise, they get the connect to FB button - this works as expected and after logging in, I can still post as them.

    Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic