WordPress.org

Ready to get started?Download WordPress

Forums

Simple Facebook Connect
Client can't connect, but I can (6 posts)

  1. workshed
    Member
    Posted 2 years ago #

    Hi, I have a client set up with Simple Facebook Connect. When he edits a blog post and clicks on "Publish to Facebook Fan Page," he gets the following error:

    An error occurred with NetAudioWeb. Please try again later.

    However, when I do it, it goes through every time.

    We've tried all of the below:

    - Checked that URLs match
    - Made sure he didn't have an adblocker stopping the request
    - Had him try from multiple networks
    - Tried different browsers
    - Had him clear cache
    - Reconnected Facebook app to plugin
    - Updated plugin

    I'm sort of at my wit's end. No idea why it works for me and not him.

    Any ideas?

    Thanks!

    -Bret

    http://wordpress.org/extend/plugins/simple-facebook-connect/

  2. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 2 years ago #

    He has to be an admin of the Fan Page to use the manual publisher buttons. If he's not an admin of the page, he can't publish to it.

    Automatic publishing doesn't have this requirement. It uses the credentials of whoever set it up in the first place.

  3. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 2 years ago #

    If he's already an admin, make sure he's not actively logged in as the page. He needs to be logged in as himself, using his own identity on FB.

  4. daMoose52
    Member
    Posted 2 years ago #

    I've actually got the same issue going on. Thing is, it was working perfectly for a while and then notta.
    I use the plugin for my game design pages (facebook.com/finaltwilightcg, facebook.com/pages/Neo-Productions-Unlimited/333323906681356) to report updates from the sites to the FB pages.
    The application is set up on Facebook to work with anything coming off my domain (neoproductions.net) and each site has the proper application IDs and secret #'s - each even reports correctly acquiring the tokens needed to do what it does.
    Now, the only possibility I can come up with that I don't use the new Timeline profile personally. Has anyone else had experience with that and how it interacts?

  5. workshed
    Member
    Posted 2 years ago #

    Yeah, my client had the same issue. It worked for awhile then stopped. I've not heard back from him, as he's been on vacation, but will post back here if we can get it fixed.

  6. daMoose52
    Member
    Posted 2 years ago #

    You know, I think I found it...another site using a lot of FB code was kind enough to tell me "A browser setting is preventing you from logging in. Click here to fix it." So, I took a look; I had turned off accepting third-party cookies, which leads the software for FB connections to fail~ Make sure the appropriate browser has that enabled ^_^

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic