WordPress.org

Ready to get started?Download WordPress

Forums

Simple Facebook Connect
[resolved] can't get anything to show up besides like btn.. (25 posts)

  1. trademarq
    Member
    Posted 3 years ago #

    Help! I'm working on a site for a friend's school group and I thought SFC would be a cool addition. But I can't get most of it working.

    http://www.ksuaasa.com is the site.

    This is probably my fault for using a wordpress generator to make the site, and I'm willing to make changes to the theme to make this work - but I have no idea what needs to be changed.

    Thanks in advance for any assistance.

    http://wordpress.org/extend/plugins/simple-facebook-connect/

  2. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 3 years ago #

    I need more specific information. What are you trying to get working that doesn't work?

  3. trademarq
    Member
    Posted 3 years ago #

    Well, i think I've figured out that I need to turn on widgets and add some shortcodes before all this will work. I did not that I cant comment using FB though on posts. The wordpress fields are still there (which I don't want), and I see the words connect with facebook but its not a button that I can actually use.

  4. trademarq
    Member
    Posted 3 years ago #

    I also just added a sidebar widget for connecting to facebook, it has the same problem.

  5. trademarq
    Member
    Posted 3 years ago #

    Okay, I solved the Text only "connect to facebook" problem. But I still want to disallow comments that are not authenticated from facebook, and I seem not to have fb avatars on posted comments. Is that the way its supposed to work?

  6. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 3 years ago #

    Okay, you've got a few changes you need to make.

    First, to remove the fields, you'll need to edit your theme and just remove those fields. The FB Connect button doesn't need the fields there to work.

    To get avatars working, you'll need to figure out why they're not working. Some themes do it wrong, basically. I wrote a post describing the basic problem here: http://wordpress.org/support/topic/protip-get_avatar-usage-for-theme-authors?replies=19

    Basically, you'll need to find how your theme displays avatars and fix it to call the get_avatar function correctly. Then the SFC-Comments plugin can replace the normal avatars with Facebook ones.

  7. trademarq
    Member
    Posted 3 years ago #

    Got it. Thanks. Awesome plugin BTW.

  8. trademarq
    Member
    Posted 3 years ago #

    Okay I've found one more issue thats a big one, but if I can get this going you will be the best guy on the planet.

    In Edit Post > Post > Publish to Facebook Application: I get the following error from Facebook:

    An error occurred with KSU African American Student Alliance. Please try again later.

    I have no idea what to do.

  9. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 3 years ago #

    Edit your FB Application. Make sure the URLs on the "Web site" tab are correct.

  10. trademarq
    Member
    Posted 3 years ago #

    Thanks. All set. Your amazing.

  11. kiawin
    Member
    Posted 3 years ago #

    trademarq, how do you solve the Text only "connect to facebook" problem? I have the same issue too.

  12. sonicparke
    Member
    Posted 3 years ago #

    I've got the same problem also. I'd love to know how you solved it.

  13. kiawin
    Member
    Posted 3 years ago #

    @sonicparke

    got the answer from the plugin page FAQ.

    In your comments.php file (or wherever your comments form is), you need to do the following.

    Find the three inputs for the author, email, and url information. They need to have those ID's on the inputs (author, email, url). This is what the default theme and all standardized themes use, but some may be slightly different. You'll have to alter them to have these ID's in that case.

    Just before the first input, add this code: [div id="comment-user-details"] [?php do_action('alt_comment_login'); ?]

    (Replace the []'s with normal html greater/less than signs).

    Just below the last input (not the comment text area, just the name/email/url inputs, add this: [/div]
    That will add the necessary pieces to allow the script to work.

    The [/div] is before the endif;

  14. sonicparke
    Member
    Posted 3 years ago #

    @kiawin

    Thanks. I'm still having trouble getting it to work. Here's my code. Maybe you can see what I've done wrong.

    <?php
    
    				//IF USER IS NOT LOGGED IN
    				else:
    
    			?>
                <div id="comment-user-details"> <?php do_action('alt_comment_login'); ?>
                	<p>
    
                        <label for="author">Name<?php if ($req) echo "<span>*</span>"; ?>: </label>
                        <input type="text" class="medium" id="author" name="author" value="<?php echo esc_attr($comment_author); ?>" />
    
                    </p>
    
                    <p>
    
                        <label for="email">Email<?php if ($req) echo "<span>*</span>"; ?>: <em>Will not be published</em></label>
                        <input type="text" class="medium" id="email" name="email" value="<?php echo esc_attr($comment_author_email); ?>" />
    
                    </p>
    
                    <p>
    
                        <label for="url">Website:</label>
                        <input type="text" class="medium" id="url" name="url" value="<?php echo esc_attr($comment_author_url); ?>" />
    
                    </p>
    			</div>
    			<?php endif; ?>
  15. kiawin
    Member
    Posted 3 years ago #

    @sonicparke

    Have you activated the SFC-comment? If not, the connect button will not appear :)

  16. sonicparke
    Member
    Posted 3 years ago #

    Yes. Is there another piece of the plugin I'm missing maybe? (screenshot) That was my first problem which I thought would fix it but it didn't. I can't really see what's going wrong. It looks like it should work.

  17. sonicparke
    Member
    Posted 3 years ago #

    I'm actually having trouble getting a lot of the widgets to show up.
    Widget Config
    Code & Page

  18. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 3 years ago #

    The "Text only connect to facebook problem" is usually caused by not having wp_footer() code in your theme's footer.php file.

    Edit the footer.php of your theme, and add this right before the ending </body> line:

    <?php wp_footer(); ?>

  19. sonicparke
    Member
    Posted 3 years ago #

    @Otto

    Thanks for the response. I realized that everything with SFC works fine in other themes just not the one I'm using. It totally breaks everything except the Login which is the default WP admin "theme". So basically it's the theme's fault. Nothing from SFC works with the theme so there's something killing it. I'm not sure if it's killing something in the Base plugin or with xfbml or what.

  20. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 3 years ago #

    sonicparke: Did you fix the footer of the theme, like I just suggested?

  21. sonicparke
    Member
    Posted 3 years ago #

    I did and most of it looks like it's working now. I'm having issues with the upcoming events plugin though. Using the user ID it displays only dates and not the same ones that I see on the actual FB page.

    Thanks for the help!

  22. foodmonger
    Member
    Posted 3 years ago #

    Hi everyone,

    I'm new to wordpress and simple facebook connect. I have managed to set most of what I need at the moment with SFC and so far it seems awesome. I however seem to be having the problem of not receiving comments made on facebook on my blog.

    I have trawled the internet and read as much as I can into the problem so that I dont bother anyone with unnecessary question. I am however stumped.

    My theme is based off of the Daydream theme and I'm guessing its comments area was written before the twentyten theme. I have checked that the footer of the theme is correct. I first placed [div id="comment-user-details"] [?php do_action('alt_comment_login'); ?] in front the Daydream code and added [/div] where it should be but no dice.

    I have now got rid of part of the Daydream code and used the code @sonicparke wrote above. I still dont get a comment on the blog if a comment is writen on fb.

    I have disabled and enabled SFC-comment before and after editing the comment.php

    Am I missing something? Should I be looking somewhere else or should this be working? How long should it take for a comment posted on FB to appear on the blog?

    Thanks Otto for writing this plugin and thanks to everyone in advanced for any guidance and help.

    Cheers

    foodmonger

  23. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 3 years ago #

    The comment plugin doesn't pull comments in from FB to your site. It allows users to comment on your site by using the Facebook connect button instead of typing in their name, email, etc.

  24. foodmonger
    Member
    Posted 3 years ago #

    Ahhhhhh.......Well dont I feel smart! I miss understood that! Thanks for the reply Otto! Carry on....nothing to see here :)

  25. jeremyers1
    Member
    Posted 3 years ago #

    @foodmonger and @Otto

    I really want a plugin that does this also! I've been searching the web for one, but it doesn't appear to exist.

    It shouldn't be too hard for Facebook comments on a blog post to appear in blog comments section also, right? All you would need is some sort of RSS feed for comments on individual Facebook posts. I'm surprised no one has made one, or if they have, I'm surprised Facebook is blocking such an application.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic