WordPress.org

Ready to get started?Download WordPress

Forums

Simple Facebook Connect
Broken!! :( PLEASE FIX! (7 posts)

  1. rabbitshavefangs
    Member
    Posted 3 years ago #

    Facebook Simple Connect is broken with the latest update of WordPress 3.1

    I cannot access the app in Facebook and it just keeps resetting due to some conflict with FSC

    Here is my error every single time I attempt to POST on my blog:

    Fatal error: Uncaught exception 'FacebookRestClientException' with message 'Session key invalid or no longer valid' in /home/BLOCKED FOR PRIVACY/public_html/wp-content/plugins/simple-facebook-connect/facebook-platform/facebookapi_php5_restlib.php:3112 Stack trace: #0 /home/BLOCKED FOR PRIVACY/public_html/wp-content/plugins/simple-facebook-connect/facebook-platform/facebookapi_php5_restlib.php(1805): FacebookRestClient->call_method('facebook.users....', Array) #1 /home/BLOCKED FOR PRIVACY/public_html/wp-content/plugins/simple-facebook-connect/sfc-publish.php(388): FacebookRestClient->users_hasAppPermission('publish_stream', 'BLOCKED FOR PRIVACY') #2 /home/BLOCKED FOR PRIVACY/public_html/wp-content/plugins/simple-facebook-connect/sfc-publish.php(296): sfc_publish_automatic(3474, Object(stdClass)) #3 /home/BLOCKED FOR PRIVACY/public_html/wp-includes/plugin.php(395): sfc_publish_auto_check('publish', 'draft', Object(stdClass)) #4 /home/BLOCKED FOR PRIVACY/public_html/wp-includes/post.php(2951): do_action() #5 /home/BLOCKED FOR PRIVACY/public_html/wp-includes/post.php(2615): wp_transition_post_status('sfc_publish in /home/BLOCKED FOR PRIVACY/public_html/wp-content/plugins/simple-facebook-connect/facebook-platform/facebookapi_php5_restlib.php on line 3112

  2. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 3 years ago #

    SFC works fine with 3.1. However, the new Facebook Pages design may be slightly incompatible.

    First things first: Go to the SFC Settings page and hit Save. This will make it try to grab the session key. Make sure that you're logged into Facebook and connected and have granted the permissions to your application.

    Turning off the auto-publish option will make the error message go away, but if you want it to auto-publish (like I certainly would), then you'll have to check this setting..

    If you're trying to auto-publish to a Page, then go to the Page on Facebook, click the Edit Info link at the top of the page, then click the Your Settings link in the upper left. On this new page, there is an option that reads "Always comment and post on your page as PAGENAME even when using Facebook as YOURNAME". Make sure that option is turned ON. When you turn it off, the page publishing breaks.

  3. rabbitshavefangs
    Member
    Posted 3 years ago #

    I'm sorry Otto but I've spent 1 hour messing around in Facebook and with FSC trying to get this to work. I cannot find any of the settings you are talking about. Perhaps you could make a step by step tutorial with screenshots for your WordPress Plugin users?

    You could post it on your blog and generate traffic and ad revenue and educate us at the same time thereby killing two birds with one stone.

    Please help us out and throw us a bone here!

    Thanks!

    -Jonathan Nerdtrek
    http://www.NERDTREK.com

  4. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 3 years ago #

    ... I'm not sure I can make it any more clear than that.

    Maybe images?

    Page, Edit Info link: http://yfrog.com/h0vcnp
    Your settings tab on the Edit Info section: http://yfrog.com/gyf92p

  5. buzzter
    Member
    Posted 3 years ago #

    Hi Otto,

    i have kind of the same issue, with only some posts (didnt figure out what might be the problem here) i want to publish on fb. I do not want to publish automatically btw.

    now when the porblem occurs instead of the usual dialog with the possibility to add a few words, there is just the fb logo with a link to the site itself.

    can you help me out with that?

    regards and thanks for your great plug in!

    buzzter

  6. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 3 years ago #

    I do not want to publish automatically btw.

    The particular issue only happens when you have the automatic publish checkboxes turned on.

    If you have another unrelated issue, please start a new topic for it.

  7. Airic
    Member
    Posted 3 years ago #

    @buzzter: did you activate the https navigation on FB recently? If so turn it off and give it a try...

    Eric From Paris France

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic