WordPress.org

Ready to get started?Download WordPress

Forums

Simple Facebook Connect
Auto publish to profile not works (11 posts)

  1. kamrul06
    Member
    Posted 3 years ago #

    Auto publish to profile is not working when I created a post. It doesn't post my profile. The option of "Auto post to profile" is checked/ticked in Simple Facebook Connect option. Moreover, Offline & Publish Permission are also granted (default). But nothing posted :(

    Please help

  2. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 3 years ago #

    Make sure you Save the settings screen after granting the permissions. This allows the plugin to go talk to FB and get the necessary tokens and such. You'll see a "ready to go" message on the settings screen when it's working.

  3. kamrul06
    Member
    Posted 3 years ago #

    Thanks for your help. But still no luck. In settings panel, "User ID and Session Key found! Automatic
    publishing is ready to go!" text is appeared. But still not working :( Morever, after publishing a post to wordpress, an option appeares in the right corner of the side panel to publish this post to profile and application. I tried both options. Publishing to application works perfectly but publishing to profile doesn't work :( I don't recognize wheres the actual problem..please help.

    [Please note: In the "Site Url" field of my application is "http://www.mysite.com/blog/" (where "blog" is the directory of wordpress) and "Site Domain" field remains empty. Please note that in "Generel>Setting" of wordpress, I enterd my site name in "wordpress url" and "blog url" with "www" . For that, I entered the link in app's "Site Url" field with "www" with blog path (/blog/)
    Please correct me if I doing any wrong.]

  4. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 3 years ago #

    You aren't logged in to Facebook as a Fan Page or something like that, are you? For publishing to work, you need to be logged into Facebook as *you*. If you've used the "log in as Page" option, then you're not logged in as you anymore.

  5. kamrul06
    Member
    Posted 3 years ago #

    Thanks a lot for that info. There is no fan page of mine. Do I need to create a fan page and then logged in by "me"? Then, is it neccessary/recommended to put page id to "facebook fan page" field for auto posting in profile?

  6. -XL-
    Member
    Posted 3 years ago #

    Hi. I have the same problem with my site too.

    But what make it worse is, I don't see Publishing to application button.
    only publishing to profile and publishing to fan page.
    and that two button also didn't work.

    Auto publish didn't work also.
    I already put everything (fan page id, Facebook API Key, etc)

    Thanks.

  7. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 2 years ago #

    If the manual buttons don't work, you have a much deeper problem. The manual publishing buttons don't go through the plugin at all, they are javascript and connect directly from your browser to Facebook. The plugin is not involved in that transaction at all.

    Also, if you have a Fan Page, then that replaces the Application publisher button in SFC, so you won't see the Publish to Application anymore in that case.

  8. wordpressfan
    Member
    Posted 2 years ago #

    I have a related problem. I have my personal account and then my business page. When I autopublish, the article is sent to my personal account's profile. How do I send the article to my page, instead?

  9. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 2 years ago #

    Use the Fan Page option in the SFC Settings screen. Then it can publish to a Fan Page.

  10. wordpressfan
    Member
    Posted 2 years ago #

    Otto, that solved that problem, but I notice WordPress posts auto-published to my page's wall are preappended with "0>" ("Luz Herrera Endorses Clairborne for Ithaca Mayor" on WordPress becomes "0 > Luz Herrera Endorses Clairborne for Ithaca Mayor") on Facebook.

    How do I get rid of the "0 >"? Thanks.

  11. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 2 years ago #

    No idea. If it's sending a "0 >", then you must have that in your content somehow. Perhaps you have another plugin interfering in some fashion?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic