WordPress.org

Ready to get started?Download WordPress

Forums

Sightings
Activation fails (6 posts)

  1. photosite.de
    Member
    Posted 2 years ago #

    Getting the following error message when trying to activate the plugin

    Parse error: syntax error, unexpected T_FUNCTION in /mnt/webg/XXXX/htdocs/blog/wp-content/plugins/sightings/sightings.php on line 97

    http://wordpress.org/extend/plugins/sightings/

  2. remtheory
    Member
    Posted 2 years ago #

    I"m getting the exact same error. Hrmm.

  3. aaslun
    Member
    Posted 2 years ago #

    Thanks for notifying me about this! This is now fixed in the latest version (1.3.2.1).
    The reason this happens is that you are probably running Sightings on PHP version 5.2 or earlier which does not support anonymous functions in PHP.
    Please download the latest version of Sightings or upgrade your PHP version in order to solve this.
    Thanks for trying Sightings!

  4. photosite.de
    Member
    Posted 2 years ago #

    _DIR_ is also not available in older versions of PHP and then there is a nasty bug in the loaded file (line 183) causing the whole WordPress to crach.

    Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /mnt/XXXXX/htdocs/blog/wp-content/plugins/sightings/theme-files/shortcode-sightings-map.php on line 183

    Have to ask my hosting service how to upgrade the PHP

  5. photosite.de
    Member
    Posted 2 years ago #


  6. webdez
    Member
    Plugin Author

    Posted 2 years ago #

    Yes, Sightings requires PHP 5.3 at least. Now since the release of PHP 5.4 earlier this month there's even more reason to consider upgrading.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags