WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: SI CAPTCHA for WordPress] Images doesn't show and audio gives error (10 posts)

  1. traypup
    Member
    Posted 5 years ago #

    Hi there,

    All of my permissions are correct, but my CAPTCHA image won't show up on the registration page. When I click the audio button, a new tab opens with an Internal Server Error.

    Page in question: http://www.thememoryzone.com/blog/wp-login?action=register

    I only want this on the register page, not comments as users must be registered to comment.

    Thanks for any suggestions you might have!

    http://wordpress.org/extend/plugins/si-captcha-for-wordpress/

  2. Mike Challis
    Member
    Posted 5 years ago #

    After the plugin is activated, you can configure it by selecting the Captcha options tab on the Admin Plugins page.
    Check the setting for CAPTCHA on Register Form: - The check box for "Enable CAPTCHA on the register form" should be checked.

    Troubleshooting if the CAPTCHA form fields and image is not being shown:
    Do this as a test:
    Activate the SI CAPTCHA plugin and temporarily change your theme to the "WordPress Default" theme.
    Does the captcha image show now?
    If it does then the theme you are using is the cause.

    Did you try testing with the default theme?
    Try that to rule out your theme being the cause. Let me know the result.

    Check and make sure the permission on all the captcha-secureimage
    folders are set to permission: 755

    all these folders need to be 755....
    captcha-secureimage
    - audio
    - gdfonts
    - images

    Did this fix it?

  3. traypup
    Member
    Posted 5 years ago #

    Thanks for your reply, Mike

    - I double-checked the setting for the CAPTCHA on register form and it was correct.
    - I tried the WP default theme and I still had the same problem of no CAPTCHA image and an error when I try the audio button.
    - I double-checked the permissions again and everything is correct.

    I even upgraded it today and still no joy. Suggestions?
    thanks,
    Tracey

  4. Mike Challis
    Member
    Posted 5 years ago #

    Tracey,

    If you can access the Apache server error_log, I would like to know what the error log entry is for securimage_show.php when it gets the 500 Internal Server Error.
    The error_log will normally have more detailed info about the cause of the error.

    Let me know what you find.

  5. traypup
    Member
    Posted 5 years ago #

    the filename securimage_show.php doesn't show up in my error log at all. Is that normal?

  6. Mike Challis
    Member
    Posted 5 years ago #

    some servers are configured with PHP error logging off by default. See if your control panel has an error log on/off button under the PHP settings. or ask your server administrator how to turn it on.

  7. traypup
    Member
    Posted 5 years ago #

    PHP error logging is on and that file is not in the log. What should I try next?

  8. Michael Bryn
    Member
    Posted 5 years ago #

    I am having the exact same problem and tried all of the fixes too. I am still having problems viewing the image. Audio is fine.

  9. Mike Challis
    Member
    Posted 5 years ago #

    Michael, just for a test...
    can you view an image if you go directly to this url on your blog?
    wp-content/plugins/si-captcha-for-wordpress/captcha-secureimage/securimage_show.php

  10. Mike Challis
    Member
    Posted 5 years ago #

    I am adding this new information for anybody who searches about this problem:

    I added a feature in version 1.7.6 (29 Aug 2009) that can be used to test if your PHP installation will support the CAPTCHA: Open this URL in your web browser to run the test: /wp-content/plugins/si-captcha-for-wordpress/captcha-secureimage/secureimage_test.php
    This link can be found on the Captcha Settings page.

Topic Closed

This topic has been closed to new replies.

About this Topic