WordPress.org

Ready to get started?Download WordPress

Forums

SI CAPTCHA Anti-Spam
You broke my slideshow (7 posts)

  1. puffidredz
    Member
    Posted 3 years ago #

    I dont know what you did prior to 2.6.5 version but ever since I did the update, it broke my slideshow. My slideshow was working fine prior. My pictures change on the right panel but it doesn't show the picture changing in the main window; it stays on the first picture. If I disable SI Captcha, the slideshow works again switching pictures like it should but the moment I re-enable SI Captcha it no longer switches again. Is there something in SI Captcha options I need to change or is this version incompatible with my web site and I need to go back to previous version?

    http://shaunieowens.com

  2. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry you are having trouble.

    Is it the .featured panel on the front page that is not working?
    It uses jquery. My CAPTCHA does not load anything on your front page. I cannot find the cause. Sorry.
    Perhaps you could contact the theme developer since they would know more about how the .featured panel works that I do.

    Mike

  3. puffidredz
    Member
    Posted 3 years ago #

    Yes. it is the .featured panel that stopped working. I will contact the developer of the theme. I notice that this usually happens when theres any plugin I download to WP that involves graphics. Thanks for the quick reply.

  4. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Your theme is using the google jquery api, that might be the conflict.

    On line 1376 of si-captcha.php I have this code:
    wp_enqueue_script('jquery');

    if you would like to help me figure it out....
    For a test, please comment that out like this:
    //wp_enqueue_script('jquery');

    Then test your front page, let me know if it started working or not.
    If it does, On the captcha settings page you can change the setting:
    Select the method of delivering the CAPTCHA form style:
    “External Style Sheet CSS”
    , then click 'help' and then copy the CSS to your theme style.css

    Then it does not use the jquery.

    But I would still like to figure out a automated solution.

    Mike

  5. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    I think the problem is your theme, it has hardcoded googleapi.com jquery in the header.php
    The proper way for a theme to to add the googleapis.com jquery is to use wp_enqueue_script
    http://codex.wordpress.org/Function_Reference/wp_enqueue_script

    wp_deregister_script('jquery');
    wp_enqueue_script('jquery', MYURL .'http://ajax.googleapis.com/ajax/libs/jquery/1.4.4/jquery.min.js', FALSE, '1.4.4');

    Otherwise they both try to load and conflict.
    A plugin has to be able to load jquery for themes that do not have it. So then themes that require it, should always deregister it, then use wp_enqueue_script so that conflicts will not happen.

    Note: The code I posted is a sample, not the specific requirement for your theme.

  6. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    I played around with your theme just for the fun of it and to learn more about the problem in case someone else has the problem. The theme definitely is not WP 3.0 compliant. .. and if you turn debug on, the theme has many warnings. WP 3.0 compliant themes are important if you ask me.
    I was able to fix the problem in the theme. If you want the new header.php
    contact me here:
    http://www.642weather.com/weather/wxblog/support/

  7. puffidredz
    Member
    Posted 3 years ago #

    Cool. I sent a message via your link.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic