WordPress.org

Ready to get started?Download WordPress

Forums

SI CAPTCHA Anti-Spam
returning visitors can't comment any more (5 posts)

  1. Ramrod
    Member
    Posted 2 years ago #

    Hi!

    Starting to have problems with this plugins CAPTCHA feature.
    Readers can't leave comments on my blog.

    They receive "Error: You did not enter a CAPTCHA phrase. Press your browser's back button and try again.".

    I have the CAPTCHA enabled only on comments.
    You can't register on our site, so when they have commented once, there are cookies saved on their computers so when they return you don't need to fill in your name and stuff again and of course they don't see any CAPTCHA box, but when they try to comment they get that error message above.

    I'm using latest WordPress and latest Mystique Theme and latest IS CAPTCHA Anti-Spam.
    I've tried to uncheck the "Hide CAPTCHA for registered users" but that didn't help.

    So now I have the CAPTCHA thing disabled, until I get a solution of the problem. I wouldn't want to change to any other CAPTCHA plugin because I like this.

    Thanks on beforehand,
    Ramrod

    http://wordpress.org/extend/plugins/si-captcha-for-wordpress/

  2. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    Maybe another plugin is conflicting.
    Look on the Admin - Plugins - menu.
    Temporarily Disable (not uninstall) all your other plugins.
    Does it work now? If yes, Activate the plugins one by one to determine
    which one conflicts. Which plugin was causing it?

    -----------------

    It could be the theme you are using is causing it...
    Do this as a test:
    In Admin, click on Appearance, Themes.
    Temporarily change your theme to the stock theme:
    “WordPress Default” (default for WP 2.0+)
    “Twenty Ten” (default for WP 3.0+)
    “Twenty Eleven” (default for WP 3.2+)
    It does not cause any harm to temporarily change the theme and change back.
    Does it work properly now?
    If it does then the theme you are using is the cause.

  3. Ramrod
    Member
    Posted 2 years ago #

    I haven't tried anything of the things you mention yet, but there wasn't any of this problem before and we haven't added any other plugins. I will try the theme thing later on.

    I forgot to mention one other thing, when you come back for commenting again it says "Welcome back "name" on the commentbox, then you have the "change" button after that Welcome Back, you know?

    But when you press there, nothing happens, you only go to the top of the post.

  4. shappyhopper
    Member
    Posted 2 years ago #

    Hi there, the last post I can see says 18 hours ago, but if I'm resurrecting a dead thread very sorry.

    Anyway I too am having this exact same problem (same theme etc), but only people using Internet Explorer 8 are having trouble; all other browsers (maybe not IE9, I have not checked yet) are fine.

    Could be down to Internet Explorer?

    If you delete all temporary internet files the Captcha box re-appears (as long as you restart IE8).

    Not really a problem for me (low traffic, alternate contact form etc) but might help to fix this issue.

  5. Ramrod
    Member
    Posted 2 years ago #

    Shappyhopper, this happens for me in both IE9 and FF8, when I started this thread it was IE8 and FF7 I think.
    If you delete the comment cookie everytime, there isn't a problem posting a comment with the captcha. But that isn't a solution in the long run. But if you keep it, the second time you comment, you get the error.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic