WordPress.org

Ready to get started?Download WordPress

Forums

SI CAPTCHA Anti-Spam
Image not showing (10 posts)

  1. kevinvaughn
    Member
    Posted 2 years ago #

    I have followed all of the troubleshooting information provided on the WordPress site plugin FAQ page, the developer's site (http://www.fastsecurecontactform.com/captcha-image-not-showing-si-captcha-anti-spam) and also the test php link (http://www.knowledgeinfusionnetwork.com/wp-content/plugins/si-captcha-for-wordpress/captcha/test/index.php) and still cannot see the CAPTCHA image. Not sure where to go from here, any assistance would be greatly appreciated...

    http://wordpress.org/extend/plugins/si-captcha-for-wordpress/

  2. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    Send the test php link to your web host support an ask them to fix there broken PHP sessions. They need to fix the session directory to be available to PHP. It is a PHP server configuration problem, something the web host should easily fix for you.

    The error:
    Warning: session_start() failed: No such file or directory.

    Mike

  3. kevinvaughn
    Member
    Posted 2 years ago #

    Thanks Mike, I will definately do this!

  4. crs1138
    Member
    Posted 2 years ago #

    Same problem here. I've checked the right, they're ok, I've emailed my host (GoDaddy) and here is answer - seems to me they have no idea, what I want them to do. I have access to php.ini, would that be helpful?

    My host response:

    Thank you for contacting Online Support. It is my understanding you are having trouble with your website. This error is caused if the your PHP scripts are printing to the browser prior to sending headers. A common example is printing the html tags prior to starting a session, or setting a cookie. The error tells the line that needs to be altered. To resolve this error remove the lines from the PHP code that are printing to the browser prior to sending headers.

    Please let us know if you have any further questions, comments, or concerns. Our service departments and telephone lines are open 24 hours a day, 365 days a year to accommodate your needs anytime.

    You can reach us by phone at any time at (480) 505-8877, or simply reply to this email.

    Please let us know if we can assist you in any other way.

    Sincerely,

    Anna P.
    Online Support Team

  5. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    crs1138,

    If you have the error: "Warning: session_start() failed: No such file or directory." Then their answer is not applicable to this error because if you have "No such file or directory" that is the problem. They need to fix the "No such file or directory" condition or PHP sessions will never work at all period!

  6. crs1138
    Member
    Posted 2 years ago #

    Thanks Mike, there is really no need for exclamations. Remember, I am the one caught up in between. And so far no one was able to help me. May be if you tell me, what exactly do you want my hosting provider to do. I mean a wee bit more than just "<i>They need to fix the condition...</i>"
    I appreciate your time and effort. Thank you.

  7. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    If you show them the error, look where says No such file or directory, it also prints the session directory and file name where the session file is trying to write to. What they need to do is either make the folder if it is missing, or if it is there, then adjust permissions / ownership for PHP to write to it. This is ordinary server admin stuff that their admins should be able to easily do in a couple minutes.

  8. crs1138
    Member
    Posted 2 years ago #

    Thanks Mike, I could fix that myself, once you pointed out what the error message means. Can you tell me what should be the right permission for the tmp folder? I've set it to 755 at the moment, but don't know if that's the right or not.

  9. orb4242
    Member
    Posted 2 years ago #

    if captcha image doesn't show, just create an empty "sessions" folder on wordpress root directory and that's done.

  10. kim00o
    Member
    Posted 2 years ago #

    it's not work with me too

    العاب

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic