WordPress.org

Ready to get started?Download WordPress

Forums

SI CAPTCHA Anti-Spam
Captcha Phrase Not Showing Up (18 posts)

  1. abhinavkaiser
    Member
    Posted 3 years ago #

    Hi,

    I have used SI Captcha on quite a few websites and I know it works like a charm every time. Recently, I tried it on http://technopedia.info/tech. It installed fine but the captcha phrase is not visible. I don't find it anywhere and all the settings and the folder is chmod 777 as well.

    I was not sure if it was installed, so I tried to comment but it said that I have not keyed in the right captcha phrase. So, I know that everything seems to be working fine but the phrase is not showing up.

    Thanks in advance!

    Abhinav Kaiser

  2. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    I need to see a page with the problem on it to be able to possible tell you what is wrong.

    Warning: Your web host has not upgraded from PHP4 to PHP5. PHP4 was officially discontinued August 8, 2008 and is no longer considered safe. PHP5 is faster, has more features, and is and safer. Using PHP4 might still work, but is highly discouraged. Contact your web host for upgrade support.

  3. mendozatj
    Member
    Posted 3 years ago #

    Try my blog to see the problem
    http://www.kntmendoza.net

  4. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Check the WP settings in Admin - Settings - General
    WordPress address (URL)
    Blog address (URL)

  5. mendozatj
    Member
    Posted 3 years ago #

    Do I need to make any changes to the Plug in files and match the settings on the URL? I'm sorry, just installed the plug in today and my PHP is newer the 5.0
    While testing the Plug in I get this error:
    "The requested URL /wp-content/plugins/si-captcha-for-wordpress/captcha-secureimage/test/index.php was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

    Thanks

  6. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    No you do NOT need to change the plugin files.

    Tell me what these settings are because one of them is not correct:
    Check the WP settings in Admin - Settings - General
    WordPress address (URL)
    Blog address (URL)

  7. mendozatj
    Member
    Posted 3 years ago #

    WordPress Address: http://kntmendoza.net/workshop1
    Site Address: http://www.kntmendoza.net

    Thanks

  8. mendozatj
    Member
    Posted 3 years ago #

    Problem has been fixed. All I needed to do is match both URL
    Beginners mistake

    Thanks

  9. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    What exactly did you change it to? I might make a FAQ page.

    Mike

  10. mendozatj
    Member
    Posted 3 years ago #

    Because I have WP installed on my web host
    WordPress Address (URL): http://kntmendoza.net/workshop1
    Site Address (URL): http://www.kntmendoza.net

    Made the change on the WordPress Address to the full name (www) so now both look as follows.

    WordPress Address (URL): http://www.kntmendoza.net/workshop1
    Site Address (URL): http://www.kntmendoza.net

  11. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks

  12. abhinavkaiser
    Member
    Posted 3 years ago #

  13. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

  14. abhinavkaiser
    Member
    Posted 3 years ago #

    Mike,

    It's all in place, everything that is mentioned on the FAQ page. But, it still doesn't show up.

    Other observations:

    1. I try to post a comment, and it says that I haven't entered a captcha.
    2. I am still getting spam comments.

    Abhinav

  15. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Abhinav,

    I recommend Akismet, it is compatible, it compliments my plugin. But other anti-spam plugins can cause this.

    Maybe another plugin is conflicting.
    Look on the Admin - Plugins - menu.
    Temporarily Disable (not uninstall) all your other plugins.
    Does it work now? If yes, Activate the plugins one by one to determine
    which one conflicts. Which plugin was causing it?

    -----------------

    It could be the theme you are using is causing it...
    Do this as a test:
    In Admin, click on Appearance, Themes.
    Temporarily change your theme to the "WordPress Default" theme, or "Twenty Ten" (default for WP 3.0).
    It does not cause any harm to temporarily change the theme and change back.
    Does it work properly now?
    If it does then the theme you are using is the cause.

  16. abhinavkaiser
    Member
    Posted 3 years ago #

    Mike,

    I think it's the theme. I ran a preview with twenty ten, and captcha showed up.

    I guess I need to change my theme.

    Any idea how comments are still getting posted given that captcha is not showing up, and people cannot post comments through my website?

    Abhinav

  17. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Missing CAPTCHA on comment form?
    You may have a theme that has a not properly coded comments.php

    When diagnosing missing CAPTCHA field on comment form....
    The version of WP makes a difference...

    (WP2 series)
    Your theme must have a
    <?php do_action('comment_form', $post->ID); ?>
    tag inside your /wp-content/themes/[your_theme]/comments.php form. Most WP2 themes do. The best place to locate the tag is before the comment textarea, you may want to move it if it is below the comment textarea.

    (WP3 series)
    Since WP3 there is new function comment_form inside
    /wp-includes/comment-template.php
    Your is theme probably not up to current code to call that function from inside comments.php.
    WP3 theme does not need the do_action('comment_form'... code line inside
    /wp-content/themes/[your_theme]/comments.php.
    Instead, it uses a new function call inside comments.php:
    <?php comment_form(); ?>
    If you have WP3 and still have the missing captcha, make sure your theme has
    <?php comment_form(); ?>
    inside /wp-content/themes/[your_theme]/comments.php
    (look inside Twenty Ten theme for proper example)

  18. abhinavkaiser
    Member
    Posted 3 years ago #

    It worked like a charm. I replaced with the new function and took out the old.

    Thanks Mike!

    On the long run, I think I might have to replace the theme. I don't know what else is not working.

    Thanks again!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic