WordPress.org

Ready to get started?Download WordPress

Forums

SI CAPTCHA Anti-Spam
captcha not appearing at all (19 posts)

  1. domainplanet
    Member
    Posted 3 years ago #

    I have installed SI CAPTCHA (just for registration) but nothing appears:

    http://xn--ecktc.net/sign-up/

    I am guessing it is because the theme uses a custom sign-up page?

    Is there any PHP code I can insert to add the CAPTCHA stuff to this custom form?

    thanks,

    http://wordpress.org/extend/plugins/si-captcha-for-wordpress/

  2. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    > I am guessing it is because the theme uses a custom sign-up page?
    yes

    Try adding the same do_action and apply_filters the original registration page had. If that does not work I can't help you because you have modified the WP files.

    do_action('register_form');

    $errors = apply_filters( 'registration_errors', $errors, $user_login, $user_email );

  3. crs1138
    Member
    Posted 3 years ago #

    I can't see the captcha at all either. http://www.planxdesign.eu/2010/02/22/logo-florecer/#comments

  4. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    crs1138,

    What version is your WordPress?

    It could be a theme causing it...
    Do this as a test:
    Activate the SI CAPTCHA plugin and change your theme to
    the "WordPress Default" theme.
    Log out of Admin and test the captcha as a normal user.
    Does the captcha work properly now?
    If it does then the theme you are using is the cause.

    When diagnosing missing CAPTCHA field on comment form....
    The version of WP makes a difference...

    (WP 2 series) Your theme must have a
    <?php do_action('comment_form', $post->ID); ?> tag inside your comments.php form. Most themes do. The
    best place to locate the tag is before the comment textarea, you may
    want to move it if it is below the comment textarea.

    (WP 3 series with a proper WP3 theme does not need this step, but if you have WP3 update to plugin version 2.5.2 or higher, if you still have the missing captcha, try above WP Series 2 steps)

    See here:
    http://wordpress.org/support/topic/392558?replies=3

  5. crs1138
    Member
    Posted 3 years ago #

    Thank you for your prompt response. Sorry for not complete info. I'm running WP3.0.1 with an adapted theme from earlier WP version.

    Ok, it is the theme, what causes the problem, but CAPTCHA won't appear even when I added the recommended line of code into my comments.php. Any ideas what to do next?

    Also is there any way, how to get the CAPTCHA to work with forms on the page? These are actually, where the most of the spam comes from.

  6. crs1138
    Member
    Posted 3 years ago #

    Sorry my mistake, I was checking it while logged in as admin. It works just fine. Thanks again.

    Still I'd be interested if there is any way, how to get the CAPTCHA to work with forms on the page? These are actually, where the most of the spam comes from. I'm using a plugin Contact Form 7 v2.4.1 to generate the plugins.

  7. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    This is the form you need: (I made this one)

    Fast Secure Contact Form
    http://wordpress.org/extend/plugins/si-contact-form/
    http://www.fastsecurecontactform.com/

  8. crs1138
    Member
    Posted 3 years ago #

    Thanks Mike, but my form has bit more fields, it's kind of a survey, rather than just a contact form.

  9. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Then you need to make your own custom integration.
    here is s free library
    http://www.phpcaptcha.org/

  10. Aines
    Member
    Posted 3 years ago #

    I'm sorry, but the same :(

    WP version 3.0.1
    PHP version 5.0

    After activating plugin there is the picture:

    http://img823.imageshack.us/img823/745/captchac.jpg

    Could you help, please?

  11. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Aines,
    I need URL to site to help you. It could be a permission problem, PHP problem, or Site URL problem.

  12. Aines
    Member
    Posted 3 years ago #

    No problem. Here it is: http://jinnbaskoff.com/contacts

  13. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Aines,

    That site does not come up, is the URL correct?

  14. Aines
    Member
    Posted 3 years ago #

    Mike Challis, yep, everything's ok. Link is correct and I can visit it.

  15. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Look in your PHP error log, tell me what you find?

  16. Aines
    Member
    Posted 3 years ago #

    [Mon Oct 18 01:13:42 2010] [notice] Accept mutex: flock (Default: flock)
    [Mon Oct 18 01:14:01 2010] [notice] SIGUSR1 received.  Doing graceful restart
    [Mon Oct 18 01:14:01 2010] [error] VirtualHost 10.1.119.109:0 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Mon Oct 18 01:14:01 2010] [error] Failed to resolve server name for 10.1.119.109 (check DNS) -- or specify an explicit ServerName
    [Mon Oct 18 01:14:01 2010] [notice] Apache/1.3.37 (Unix) PHP/5.2.10 configured -- resuming normal operations
    [Mon Oct 18 01:14:01 2010] [notice] Accept mutex: flock (Default: flock)
    [Tue Oct 19 00:01:29 2010] [notice] SIGUSR1 received.  Doing graceful restart
    [Tue Oct 19 00:01:31 2010] [error] VirtualHost 10.1.119.109:0 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Tue Oct 19 00:01:31 2010] [error] Failed to resolve server name for 10.1.119.109 (check DNS) -- or specify an explicit ServerName
    [Tue Oct 19 00:01:31 2010] [notice] Apache/1.3.37 (Unix) PHP/5.2.10 configured -- resuming normal operations
    [Tue Oct 19 00:01:31 2010] [notice] Accept mutex: flock (Default: flock)
    [Wed Oct 20 00:01:38 2010] [notice] SIGUSR1 received.  Doing graceful restart
    [Wed Oct 20 00:01:45 2010] [error] VirtualHost 10.1.119.109:0 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Wed Oct 20 00:01:45 2010] [error] Failed to resolve server name for 10.1.119.109 (check DNS) -- or specify an explicit ServerName
    [Wed Oct 20 00:01:46 2010] [notice] Apache/1.3.37 (Unix) PHP/5.2.10 configured -- resuming normal operations
    [Wed Oct 20 00:01:46 2010] [notice] Accept mutex: flock (Default: flock)
    [Thu Oct 21 00:01:40 2010] [notice] SIGUSR1 received.  Doing graceful restart
    [Thu Oct 21 00:01:42 2010] [error] VirtualHost 10.1.119.109:0 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Thu Oct 21 00:01:43 2010] [error] Failed to resolve server name for 10.1.119.109 (check DNS) -- or specify an explicit ServerName
    [Thu Oct 21 00:01:43 2010] [notice] Apache/1.3.37 (Unix) PHP/5.2.10 configured -- resuming normal operations
    [Thu Oct 21 00:01:43 2010] [notice] Accept mutex: flock (Default: flock)
  17. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    The errors log does not show any entries related to the captcha plugin.

    I can only suspect there is a PHP problem though, perhaps your PHP server does not support the GD image functions because the test page will not load.

    or it could be a permissions problem.
    http://codex.wordpress.org/Changing_File_Permissions

  18. an52
    Member
    Posted 3 years ago #

    I am using the latest Thesis theme on two blogs on the same server. Both use the default template. Same settings for the plugin. The SI CAPTCHA plugin works on one fine (http://www.netmagellan.com/contact) but not on the other (http://www.guptill.info/contact/). No code in the custom files regarding the form.

  19. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    This plugin is NOT for contact forms, it is only made for WordPress comments, login, and registration.

    For contact form CAPTCHA use this 5 star contact form plugin I authored:
    Fast Secure Contact Form
    http://wordpress.org/extend/plugins/si-contact-form/

    Mike

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic