WordPress.org

Ready to get started?Download WordPress

Forums

SI CAPTCHA Anti-Spam
[resolved] Captcha input not recognized occasionally (11 posts)

  1. hamdiakoguz
    Member
    Posted 3 years ago #

    We get complaints from readers that they can not post comments due to captcha error. I even got screenshots proving the issue.

    I don't think that it is related to other plugins enabled or browser cookie settings since complaintive users say that it does not happen always.

    Has anyone experienced this kind of problem ?

  2. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    I can help better with a URL to your site.

    If you sit on the page beyond the PHP session timeout this can happen.
    PHP session is usually 30 minutes by default but may have been changed in php.ini

  3. hamdiakoguz
    Member
    Posted 3 years ago #

    Our blog lives here.

    Thanks. I'll check php session timeout value.

  4. hamdiakoguz
    Member
    Posted 3 years ago #

    Further testing reveals that when a user opens multiple posts on different browser tabs only the most recently loaded captcha works because only the last one is set in the session. You can comment to previously opened post with the last loaded captcha.

  5. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Why are you using an old version of this plugin?
    Update it and the problem should go away, let me know.

    Mike

  6. hamdiakoguz
    Member
    Posted 3 years ago #

    I don't know how i ended up with an older version.

    Thanks. Updating solved the problem.

  7. jim.ellison
    Member
    Posted 2 years ago #

    Hi, certain readers who try to comment say if they don't hit the Submit button post the comment in fewer than a couple minutes, the message won't go thru as the Captcha image has evidently timed out.

    How does one increase that number of minutes? Is it at the server level or within the si-Captcha script?

    Thanks, Jim Ellison, Roanoke, Va.

  8. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    It depends on the setting "Use CAPTCHA without PHP session." on the plugin settings page.

    If it is checked(default):
    The default timeout is 30 minutes. If it times out because of more than 30 minutes on the page, you could click the captcha refresh button to get a fresh timer started.

    If it is not checked:
    PHP session cookie timeout is in effect.
    Your php.ini may have this setting set to a lower number than you want.
    session.cookie_lifetime

  9. jim.ellison
    Member
    Posted 2 years ago #

    Thanks, Mike!

  10. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    I edited my answer with more info.

  11. jim.ellison
    Member
    Posted 2 years ago #

    Most excellent. Thanks again.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic